It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

hook does not fire after local commit

Hi,

I have a drone.io account, offering me the possibility to have automated builds for my Go project that I host in a Bitbucket Mercurial repo. This works fine when I push changesets to the repo from my local machine.

But when I do a local commit on the Bitbucket site, the Post hook for the drone.io CI is not fired.

Is that a shortcoming, and so should I register a bug? Or is there a reason behind this behaviour?

Regards,

Johan

3 answers

1 accepted

0 votes
Answer accepted

Hi,

This problem is solved with the solutiob provided thru Atlassian issue 9187.

see https://bitbucket.org/site/master/issue/9187/bitbucket-post-hook-not-triggered-by

Thanks very much for the good work.

0 votes
aMarcus Atlassian Team Feb 18, 2014

You can check to see if your repo is firing what you would expect by following our guide to testing. Please give it a try, then come to support if you don't find a solution.

I read that page, Marcus, but it says nothing about testing the working of the Post hook after a Bitbucket local commit. (For clarity: by local commit I mean editing a file via the browser on the Bitbucket site itself, and then commit it from there.)

aMarcus Atlassian Team Feb 19, 2014

When editing a file online (In Bitbucket, in your web browser), the hooks fire exactly the same as when you commit and push locally (on your own machine).

I tried again, to no good. The local commit (1a853ccf1632) did not trigger a drone.io build. The last build on drone.io shows the one for cset 88dd6249717e. This concerns my public repo bitbucket.org/gohg/gohg, if you wonder. I tried it with another repo of mine, also configured with drone.io, and it has the same problem.

In case you should follow the drone.io button in the overview page of the gohg repo, you will see a (failed) build on drone.io for cset 1a853ccf1632. But that is one I just triggered manually from the drone.io site itself, for testing something there.

Just to make sure you're not confused by that build :) .

(I'll ask the guhys at drone.io if they could mark manual builds as such.)

Hi Marcus,

I tried the test with http://posttestserver.com, but the result is the same. All goes well when I push changes to the different repos, but a commit after editing in the browser on the Bitbucket website does not trigger any POST hook.

So to me it is clear that neither the repo (I tried two different repos) nor the called services (I tried two different services, one of which recommended by the document you referenced) are the cause of the issue.

Maybe it could indeed be something with the Bitbucket POST hook not firing after a commit from the Bitbucket website?

Regards, Johan

Marcus,

I also added an Email Hook, and that one too only fires when I push changes, but not when I do a commit via the Bitbucket website.

I guess this confirms that this is an issue, and not some misconfiguration.

Regards, Johan

aMarcus Atlassian Team Mar 23, 2014

Can you come to support so we can take a closer look? Please include the full URL of your repository. support@bitbucket.org

This problem is solved with the solutiob provided thru Atlassian issue 9187.

see https://bitbucket.org/site/master/issue/9187/bitbucket-post-hook-not-triggered-by

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Halp

Halp - Conversational Ticketing Help Desk for internal requests

From the Halp Team Howdy!  👋   We’re Halp, a conversational ticketing help desk for all of your internal requests in Slack (and soon to be MS Teams!). We’re excited to be a par...

57 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you