git svn clone gives remote refs error

I am on Windows 7 Ultimate 64 bit, running Subversion 1.7.6 with Git version 1.8.0.mysysgit.0

I have Git running from a Bash window, not from a Windows command window

I am following the instructions to migrate my OnDemand Subversion repository to BitBucket -

Everything seemed to go well on the first section labled "Prepare." When I went to the "initial clone" page ( I ran into a few issues immediately with the git svn clone section. First of all I was getting an error that said "Expected FS format '2'; found format'4'. I found help for that which recommeded that I add the --pre-1.5-compatible flag to the svnadmin create command from the previous page. So, I remade my local SVN repository with the flag and the error went away.

I tried the command again, as follows:

$ git svn clone --trunk=/trunk --branches=/branches --tags=/tags --authors-file
=authors.txt file:////c/Temp/SVNMigration/TempProjects/TEST test.git

This returns the error:

svn-remote.svn: remote ref '/Program Files (x86)/Git/trunk:refs/remotes/trunk' must start with 'refs/'

I looked at the remote section in the git config file in my newly created test.git repository, and found the following:

[svn-remote "svn"]
	url = file:///c/Temp/SVNMigration/TempProjects
	fetch = TEST/C:/Program Files (x86)/Git/trunk:refs/remotes/trunk

Since this file was created by the process, how could it be the problem? How do I fix this?



2 answers

If someone happens to be in the same sittuation (if you search for "git config fetch = C:/Program Files (x86) remote ref" this page is the first result) I resolved this problem changing the clone command from:

$ git svn clone --authors-file=authors.txt --trunk=/trunk --branches=/branches --tags=/tags/Release git-project

to this:

$ git svn clone --authors-file=authors.txt --trunk=trunk --branches=branches --tags=tags/Release git-project

Note the removed leading slash "/" from the trunk, branches and tags parameters.

As I said, I recived this error in Windows. Switching to Ubuntu fixed the problem, although, according to the directions, Windows should have worked.

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Posted yesterday in Off-topic

Friday Fun: What's your favourite beer/drink

As a Belgian, beer-lover and home brewer, beer is one of my great passions. I love the fact that with just a few ingredients (usually just water, hop and malt) you can create so many different tastes...

246 views 35 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot