fisheye error :java.servletException -java.lang.OutOfMemoryError:GC overhead limit exceeded

i install fisheye 2.7.12 on ubuntu.

i add a git repository,and it is indexing.then error comes:

Repository index failed due to error com.cenqua.fisheye.rep.RepositoryClientException: com.atlassian.fisheye.dvcs.handler.DvcsProcessException: Error while communicating with VCS: com.atlassian.fisheye.dvcs.handler.DvcsProcessException: Error while communicating with VCS: com.atlassian.utils.process.ProcessException: While executing: /usr/bin/git whatchanged --always --reverse --date-order -m --no-abbrev --no-renames 6c24ad4e9ddae2a39f032c20b2181b045bb5b322 --pretty=format:C:%H%nP:%P%nA:%aN%nE:%aE%nR:%cN%nF:%cE%nD:%at%nS:%s%nB:%b%n@@fe_body_end@@  com.atlassian.utils.process.ProcessTimeoutException: process timed out

the command line terminal shows error message:

fisheye your request was unable to be processed,java.servletException -java.lang.OutOfMemoryError:GC overhead limit exceeded

i searched resolutions from atlassian confluence,and it says:

If necessary, this feature can be disabled by adding the option -XX:-UseGCOverheadLimit to the command line.

does it mean i shall start fisheye by run ". run.sh -XX:-UseGCOverheadLimit" ?

or is there any other better resolutions?

2 answers

1 accepted

thanks all of you,

i can increase heap memory by setting environment variable under windows xp( not run FishEye as a Windows service) successfully.

but in linux,i try vi '~/.profile' and 'vi /etc/profile' and add 'export FISHEYE_OPTS=-Xmx2048m' to those files end line.and restart fisheye by run './run.sh', but the fisheye's JVM Input Arguments still be default:

JVM Input Arguments-Xmx1024m -XX:MaxNewSize=128m -XX:MaxPermSize=256m -Dfisheye.library.path= -Dfisheye.inst=/home/crucible/fecru-2.7.12 -Djava.awt.headless=true -Djava.endorsed.dirs=/home/crucible/fecru-2.7.12/lib/endorsed
Total Memory1G
Free Memory88M

Memory Usage is neary full,and after a while,fisheye will be very slow,and even crash.

i have fix it ,'vi /etc/profile' add 'export FISHEYE_OPTS=-Xmx2048m' on its own line at the end of the file,and then source /etc/profile ,echo $FISHEYE_OPTS to checkout if you have set environment variable correctly.finally './run.sh'

Hi Fabby,

What it is saying is that you need to add the argument XX:-UseGCOverheadLimit to FishEye's startup options as described in this document: https://confluence.atlassian.com/display/FISHEYE/Environment+variables

I believe that adding a more effective GC algorithm should help improve the situation for you, but the other option, (which you should implement as well), would be to increase the Heap Memory, (by 256MB), which you can see how to do by following the instructions in this document: https://confluence.atlassian.com/display/FISHKB/Fix+Out+of+Memory+errors+by+increasing+available+memory#FixOutofMemoryerrorsbyincreasingavailablememory-OutOfMemoryError:JavaHeapSpace

All the best,
John

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Featured Groups

Want to know how Atlassians monitor their enterprise deployments?

At Atlassian, we believe in our own products – that's why we use them, even at the enterprise level. Doing so gives us first-hand experience of how they perform at scale; to do this, we monitor each ...

74 views 2 7
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you