error while compiling jira-plugin project

hi -

I setup my development environement follwoign all the steps provided in https://developer.atlassian.com/display/DOCS/Introduction+to+the+Atlassian+Plugin+SDK

when i try to compile my code using

atlas-run I get the following error

WARNING Using platform encoding (MacRoman actually) to copy filtered resources, i.e. build is platform dependent!

INFO Copying 1 resource

INFO jira:filter-test-plugin-descriptor

INFO jira:generate-test-manifest

INFO compiler:testCompile

INFO Nothing to compile - all classes are up to date

INFO jira:unit-test

INFO surefire:test

INFO Surefire report directory: /Users/e13139/source/workspace/jira-plugin/jira-report-plugin/target/surefire-reports

INFO ------------------------------------------------------------------------

ERROR BUILD ERROR

INFO ------------------------------------------------------------------------

INFO Unable to execute mojo

Embedded error: Unable to generate classpath: org.apache.maven.artifact.resolver.ArtifactResolutionException: Unable to get dependency information: Unable to read the metadata file for artifact 'org.apache.maven.surefire:surefire-junit4:jar': Cannot find parent: org.apache.maven.surefire:surefire-providers for project: null:surefire-junit4:jar:null for project null:surefire-junit4:jar:null

org.apache.maven.surefire:surefire-junit4:jar:2.12

from the specified remote repositories:

atlassian-plugin-sdk (file:///usr/share/atlassian-plugin-sdk-4.1.2/repository),

central (http://repo1.maven.org/maven2),

Releases (https://nexus:8443/nexus/content/repositories/releases/),

atlassian-public (https://m2proxy.atlassian.com/repository/public)

Path to dependency:

1) dummy:dummy:jar:1.0

no more data available - expected end tags </version></parent></project> to close start tag <version> from line 27 and start tag <parent> from line 24 and start tag <project> from line 21, parser stopped on START_TAG seen ...</artifactid> n <version>2.... @27:16

INFO ------------------------------------------------------------------------

INFO For more information, run Maven with the -e switch

INFO ------------------------------------------------------------------------

can you please help me fix this issue. I have been stuck at this issue for a long time.

Result for running > atlas-version

ATLAS Version: 4.1.2

ATLAS Home: /usr/share/atlassian-plugin-sdk-4.1.2

ATLAS Scripts: /usr/share/atlassian-plugin-sdk-4.1.2/bin

ATLAS Maven Home: /usr/share/atlassian-plugin-sdk-4.1.2/apache-maven

--------

Executing: /usr/share/atlassian-plugin-sdk-4.1.2/apache-maven/bin/mvn --version

Apache Maven 2.1.0 (r755702; 2009-03-18 14:10:27-0500)

Java version: 1.6.0_37

Java home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

Default locale: en_US, platform encoding: MacRoman

OS name: mac os x version: 10.8.2 arch: x86_64 Family: mac

4 answers

This widget could not be displayed.

I think pom.xml needs to be reconfigured.

I would suggest you create an empty plugin for the jira version you are on and then pick that pom.xml and as a template and edit that for your own plugin.

See if that helps.

Rahul

This widget could not be displayed.

I Think its the jira-core that i have referenced. I am trying to test the sample project provided in the website and I also tried to remove all the dependencies. If i do so then JIra does not get started up at the end of the compimlation.

This widget could not be displayed.

Has any one has this issue and found a way to resolve this issue. If i clean up the whole pom then i cannot compile or start JIra at the end of compilaton. Please help I am stuck with this for a while and i need a solution to proceed.

This widget could not be displayed.

I cleared the dependencies in my pom and ran atlas-run and still got the same error. Is there any thing in the atlas-run that i can override.

Thanks

Gopi

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 3 hours ago in Europe

Topic Tuesday: How did you learn about the AUG programme?

Back in 2010 I hadn't been using the Atlassian tools (JIRA, Confluence, Bamboo) that long and I started searching online to see if I could chat to other users primarily about how they used the produc...

12 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you