can't start Crowd from system user - have to use root user

I can't start Crowd from a system user. I have to use the root user.

I've followed the instructions here:

https://confluence.atlassian.com/display/CROWD027/Setting+Crowd+to+Run+Automatically+and+Use+an+Unprivileged+System+User+on+UNIX

but it doesn't actually start when I type ./start_crowd.sh as a system user.

If I'm not logged in as root, when I type ./start_crowd.sh, it LOOKS like it starts:

 

Using CATALINA_BASE: /home/myacct/apps/crowd-install-2.12/apache-tomcat
Using CATALINA_HOME: /home/myacct/apps/crowd-install-2.12/apache-tomcat
Using CATALINA_TMPDIR: /home/myacct/apps/crowd-install-2.12/apache-tomcat/temp
Using JRE_HOME: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.131-0.b11.el6_9.x86_64
Using CLASSPATH: /home/myacct/apps/crowd-install-2.12/apache-tomcat/bin/bootstrap.jar:/home/myacct/apps/crowd-install-2.12/apache-tomcat/bin/tomcat-juli.jar
Using CATALINA_PID: /home/myacct/apps/crowd-install-2.12/apache-tomcat/work/catalina.pid
Existing PID file found during start.
Removing/clearing stale PID file.
Tomcat started.

... but if I then type

ps faux | grep java

there's nothing listed, and Crowd doesn't respond when I try to load it in the browser.

 

If I run ./start_crowd.sh as root, then run ps faux | grep java , I DO see it in the output, and I can access it from the browser.

 

What can I check or try to get Crowd to run from a user that's not root?

 

((By the way, I accidentally hit Tab while typing this and ended up on the previous page, having lost everything I'd typed. Can you add a "sure you want to leave this page?" prompt so people don't lose their questions?)

1 answer

0 vote

The usual culprit of this is file ownership.  Once you've accidentally started it as root, some files become owned by root, and that stops the dedicated user from being able to write to them.

Check the file ownership across the whole installation and home directories.

HI Nic,

Thanks so much for the quick reply.

However, I confirmed that nothing is owned by root:

ls -lR crowd-install-2.12/* | grep root
ls -lR crowd-home/* | grep root


- both return no results.

But when I tried again, Crowd acts like it starts when run as non-root, but doesn't actually appear in the ps , and I have to start it as root.

Can you suggest anything else to check?

Thanks.

They could be owned by another user than root.  Sorry, I should have been more clear about that.

After checking that, move on to the log files - what do catalina.out and the confluence log say happens when it fails to start?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Marketplace Apps

Tips on how to choose the best estimation method for your planning

Planning and grooming sessions all come with their own sets of rules. Team members meet to estimate stories or other work items, all according to an agreed-upon process. And with every session comes ...

78 views 0 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you