anyone else here experiencing problems after JEMH upgrade?

just upgraded 1.2.79 to 1.3

The license is not valid for the following reasons:
  

                
* There was a SQL exception thrown by the Active Objects library:
Database:
	- name:MySQL
	- version:5.1.61-log
	- minor version:1
	- major version:5
Driver:
	- name:MySQL-AB JDBC Driver
	- version:mysql-connector-java-5.1.22 ( Revision: ${bzr.revision-id} )

java.sql.SQLException: Error on rename of './jira/#sql-7b8_18759' to
'./jira/AO_78C957_LDAPCONF' (errno: 150)

2 answers

1 accepted

This widget could not be displayed.

Yes, there is a problem with upgrades and mysql, the resolution is to drop a JEMH table that is actually empty (AO_78C957_LDAPCONF). This problem stops the AO database layer initialising, which pretty much stops everything working, documented on the Javahollic Wiki.

yes dropping that table will resolve the issue...thanks andy

This widget could not be displayed.

oh ok.

looks like it is db driver specific.

no problems upgrading on a postgresql jira instance....

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in United States

Local Atlassian Research Workshop opportunity on Sep. 28th

We're looking for participants for another workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sh...

37 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you