Where do I find Agile if it's not in the top navigation bar?

This question is in reference to Atlassian Documentation: Creating a Board

We've started a new project and want to create a scrum board, manage sprints, see the backlog, and so on. But we can't find a way to do it.

https://confluence.atlassian.com/agile/jira-agile-user-s-guide/creating-a-board says "2. Select Agile > Manage Boards from the top navigation bar." But Agile doesn't appear in the navigation bar.

I tried shortcut keys "g + d" and got back to my dashboard, but still Agile did not show up.

It used to be there. We have some projects that are already agile and still have backlog and sprint views that we can access. We're using JIRA Agile v7.2.6-D20160330T044439 plugin.

How can we get the Agile menu back?

This problem is really blocking us from using JIRA Agile.

Update

in reply to @Nic Brough [Adaptavist]'s answer:

Thanks for your reply. When I go to About JIRA, a dialog pops up saying "Atlassian JIRA and JIRA Plugins". On that dialog, the last section heading is

  JIRA Agile v7.2.6-D20160330T044439

So if that's not true, we apparently have a version reporting bug. How do I know whether to believe you over the About box? smile What you say matches the fact that the JIRA help web site only lists JIRA Agile up through 6.7... I was assuming that just meant the help web site was out of date.

As for JIRA Software, I don't see that listed as such in the about box, but it does have

  JIRA v7.2.0-OD-05-030

On the project where we're trying to get a scrum board added, there is a Boards menu option in the top navigation bar. However it doesn't show any option for creating a board.

But now, given your hint that we may be using "JIRA Software," I have started looking at the online help for JIRA Software. So that's probably one of the biggest missing pieces for me: a prominent pointer from the JIRA Agile documentation to JIRA Software, since the connection is far from obvious.

Apparently I can't post this comment on your answer until 24 hours have passed from when I posted the question. sad Because I commented on another answer. I guess I need to answer some questions, get my question upvoted, or otherwise earn 3 points.

Update 2

Thanks @Nic Brough [Adaptavist] for your comment on this question. If you were to upvote my question, would that give me enough points to comment on your answer, instead of editing my question? smile

The documentation at https://confluence.atlassian.com/agile/jira-agile-user-s-guide/creating-a-board said,

If you don't have this permission (JIRA 'Create Shared Objects' global permission) you can still create a board, but it will not be visible to other people as its filter will not be shared.

(and the newer docs for JIRA Software say something similar). So that makes me think that the "Create" option should be in the Boards menu even without that global permission. But on further digging, it appears that the ability to create a board in that case is not directly on the Boards menu (it's under Boards > View All Boards). In other words, it's not quite true that you need the permission to "create shared objects" in order to create boards, but you do need it in order have Create show up in the Boards menu. Wow. (6_9)

Anyway, I do want to create a board that's shared, so I went to the Global Permissions page and found

Create Shared Objects

Ability to share dashboards and filters with other users, groups and roles.

  • jira-users
    • View Users 
    • Delete

When I click on View Users, I get a Permission Denied page. So, I don't know whether I have that global permission. I have created boards before, and I'm pretty sure they've been shared, but it's possible that something has changed. I will ask a JIRA administrator to make sure I have that permission.

Update 3

Once again I'm unable to comment due to anti-spam rules. So, following up on my comment on your answer, @Nic Brough [Adaptavist]: The colleague I checked with was able to access the board I'd created. So it appears that the problem is solved. Thanks for your help.

If I come here again, or for anyone else having similar troubles, here are the key lessons learned:

  • If it says you're using "JIRA Agile 7.2", don't believe it; look for the documentation for JIRA Software 7.2.
  • Make sure you have the "Create Shared Objects" global permission.
  • Don't look for an Agile menu or a Boards > Create command. Instead, go to Boards > View all boards, then click the Create board button.

2 answers

1 vote

>We're using JIRA Agile v7.2.6

No, you're not - JIRA Agile is an add-on that stopped development on version 6.7, as it was replaced by JIRA Software.  I suspect you're using JIRA Software 7.2

In JIRA Software, the Agile menu option has gone.  It is replaced by the Boards menu option.  If that is not there, then you haven't got Software at all, just JIRA Core!  Which doesn't have Scrum or Kanban boards.

Looks like I'm allowed to comment now. In response to your comment on my question, the JIRA "create shared objects" global permission has "jira-users" on it (as shown in the 2nd update to my question), and our JIRA administrators say that I am in that group.

But "create" still does not show up in the Boards menu. Any other ideas?

Is jira-users only a global group, or is it possible to be in jira-users at a project level and not at a global level?

No, it's a global thing.

But I completely forgot - you also have to be a JIRA Software user, not just a JIRA user.

I don't know about that ... The JIRA Software docs at https://confluence.atlassian.com/jirasoftwarecloud/creating-a-board-764477949.html don't mention anything about being a JIRA Software user. But they also don't say anything about having "Create" (or "Manage Boards") show up in the board menu. So I stopped looking for that and did what the new docs say: I went to Boards > View all boards and then clicked on "Create board" in the upper-right corner. It let me create a board, and didn't say anything to me about it not being shared. I'm checking with a colleague to verify that it's shared. Maybe the problem is solved.

 

0 votes

Yes, the anti-spam scoring can be a bit of a pain.  And the version reporting does look broken there.  It says JIRA Software for me, but I'm on 7.1 Server. You look like you're on Cloud (which is always on "latest")

The main question though - you have "boards" in the menu, but no "create" option.  You need the permission to "create shared objects" in order to create boards - can you check that?  It's in "global permissions"

Suggest an answer

Log in or Sign up to answer
Community showcase
Published 4 hours ago in Jira Ops

Jira Ops Early Access Program Update #2: Let’s talk severity levels

Welcome to your weekly Jira Ops Early access program update, where we’re sharing news and updates on Jira Ops' progress as we work toward our 1.0 release. If you ever want to drop us feedback or idea...

18 views 0 0
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you