When I try to load a large SQL dump, why do I receive the following error: ERROR 2006: MySQL Server has gone away? To address this issue, perform the following steps: 1.Open the /etc/my.cnf file with your preferred text editor. 2.Enter max_allowed_packet=

my sql 5.5  how can I change this vaiable without ssh access. and what is the best way to do this the correct code?

how to do without ssh I'm on vps Linux  the answer here below is from cpanel/whm website.  

  1. Open the /etc/my.cnf file with your preferred text editor.
  2. Enter max_allowed_packet=# in the [mysqld] section. Replace # with a number.
  3. Save the file.
  4. Restart MySQL® with the /scripts/restartsrv_mysql script.

1 answer

This widget could not be displayed.

You need to edit the my.cnf file and restart MySQL, there's no other way to change the setting.

If you don't have command line access, then you will need to use a tool that allows you to edit the file indirectly.  In this case, as you're using cpanel, the question becomes "does cpanel have a tool to allow me to edit the settings?".  If it does not, then you are stuck with no way to edit the file.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

28 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you