WARNING The system property 'mail.mime.decodeparameters' is not set to true

Hi
in system info I get following warnings

WARNING: The system property 'mail.mime.decodeparameters' is not set to true. This may result in e-mail attachments with non-Latin filenames being dropped. For more information please see the JIRA Documentation.

WARNING: 'Apache Tomcat/6.0.32' server and the 'org.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER' system property is not set to true! This can result in OutOfMemoryErrors. For more information please see the JIRA Documentation.

But both of them are set to true already.
Here is my JVM output according to Jira from same system info page

-Dcatalina.home=C:\Program Files (x86)\Apache Software Foundation\Tomcat 6.0 -Dcatalina.base=C:\Program Files (x86)\Apache Software Foundation\Tomcat 6.0 -Djava.endorsed.dirs=C:\Program Files (x86)\Apache Software Foundation\Tomcat 6.0\endorsed -Djava.io.tmpdir=C:\Program Files (x86)\Apache Software Foundation\Tomcat 6.0\temp -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=C:\Program Files (x86)\Apache Software Foundation\Tomcat 6.0\conf\logging.properties -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -Djava.awt.headless=true -Dfile.encoding=utf-8 -XX:MaxPermSize=256m -XX:+CMSClassUnloadingEnabled -Xms1024m -Xmx1024m

1 answer

1 accepted

This widget could not be displayed.
Richie Gee Atlassian Team Mar 05, 2013

For your case, I believe that setting does not reflect properly from your description. Would you try to investigate further referring to the below documentation to see if this is the case for your problem?

Do take note on the resolution that

Ensure that each defined parameter is defined on its own line.
Ensure that there are no extra spaces at the end of the parameters.

Hope this helps :)

Thank you. I solved this long time ago but you are right it was a space that caused the problem.

Richie Gee Atlassian Team Mar 05, 2013

Thank you, I just want to share this information to other users that might bump into the same issue :)

Thanks for the update, great job solving this :)

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 54m ago in United States

Local Atlassian Research Workshop opportunity on Sep. 28th

We're looking for participants for another workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sh...

8 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you