User gets intermittent ERR_TOO_MANY_REDIRECTS error

User is able to login through the main Confluence page, but when he tries to access individual wiki pages will intermittently get a "ERR_TOO_MANY_REDIRECTS" error.  This has been occurring over the last week or so, with the ability to access a page one moment, and then loses access later.

User is using Chrome as a default, has cleared all cookies, tried loading in Incognito Mode, tried loading from a new tab, a new instance, and from Internet Explorer, all giving the same error.

No changes have been made recently to the user's profile / access.  I confirmed the user's permissions to the page, and even added him to the overall site admin group. 

3 answers

I`d recommend opening Chrome developer tools, ticking "Preserve log" and try to log on. 

Then you will see whats actually going on. 

Does this affect one user or all users?


Lars, Kantega Single Sign-on

As far as I'm aware, it is only affecting one user.  For example, I was able to access all of the pages he was not able to, despite giving him the same privileges I have.

The user is not particularly tech-savvy and lives several states away, so it may be a challenge to talk him through the steps necessary to get the developer data.  For the time being, let's assume that information won't be available.

Got the Chrome's two pages' worth of errors.  Significant/repeated errors are:

  • DEPRECATED JS - [resource specified] has been deprecated batch.js?locale=en-GB:128 since 5.8.0 and will be removed in a future release. Use [resource specified]   (there are a number of variants of this error, each specifying a different resource deprecated and what resource should be used instead.)


    Failed to load resource: the server responded with a status of 404 ()

  • Failed to run init function: TypeError: Failed batch.js?local=en-GB:369 to execute 'observe' on MutationObserver': parameter 1 is not of type 'node'.


Appreciate any help....


Just a wild guess. 

Try changing the language under the users profile. 



I have the same problem right now. I get this error after about three page hops, or every single time I update a page. The page updates, but I have to go back to the home page to get back to the updated page.

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

129 views 3 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot