Upgraded FishEye, smart commits failing to update JIRA

Hi,

Once again I've run into an issue after upgrading. The smart commits are failing. It's very weird because when I use the smart commits (Subversion), and hover over a Jira Issue # in FishEye, I get the pop-up window with an overview of the issue, so I know they can communicate. However, FishEye cannot update any issues. Here is the error everyone gets:

FishEye was unable to comment on the issue XX-123 because JIRA responded with the following error: You do not have the permission to comment on this issue.

I have made a Trusted Application Link between the 2, as well as added the admin credentials.

I've just upgraded FishEye to 2.10.x and the Jira plug-ins.

2 answers

1 accepted

This widget could not be displayed.

I'Ve solved my own issue. After looking at the Jira logs on the server, I noticed a "Certificate too old." exception. Which led me to the Certificate timeout setting on the Application link between Jira and Fisheye. Turns out our servers have a time difference of about 30 seconds and the default is 10 seconds.

Quick and dirty fix of changing that timeout value and it all worked!!

This widget could not be displayed.

Hi Josh,

Judging by your description, it seems to me related the user that made the commit on the repository not having permission to comment in JIRA.

The smart commits use the username of the person that sent the commit to identify a valid user in Fisheye/JIRA. For example, using git you have the following settings (I know SVN has something similar, but don't remember how to check):

git config --global user.name "jsmith"
git config --global user.email jsmith@company.com

So in this example, smart commits will pick the user name jsmith and try to send the comment with this credential. If the user jsmith doesn't exist or don't have permission to send a comment, you we'll see the message you're seeing in your logs.

In this case, you may change the username within the software you are using to send the commit to the repository, or within Fisheye Administration > User Settings> User Mappings, you can map the Committer username to an existent FishEye username.

I hope this helps.

Cheers

Thanks, Tiago. Our Subversion account names are different than our Jira/Fisheye account names, but I have the user mappings set up. I will try to recreate them; that's a good suggestion.

I'e solved my own issue. After looking at the Jira logs on the server, I noticed a "Certificate too old." exception. Which led me to the Certificate timeout setting on the Application link between Jira and Fisheye. Turns out our servers have a time difference of about 30 seconds and the default is 10 seconds.

Quick and dirty fix of changing that timeout value and it all worked!!

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 7 hours ago in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

13 views 0 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you