Upgraded Confluence from 4.2.8 to 4.3.2 and now we get a 404 error

I upgraded our existing Confluence installation with the 64-bit executable of 4.3.2. I followed the Confluence Installation and Upgrade Guide. Below are my installation notes.

10/22/2012 - Upgrade to Confluence 4.3.2

Backed up the DB

Backed up the install and home directories

Ran the executable file

Selected the Upgrade an existing Confluence installation option

Allowed it to backup the home directory

Here is the list of file modifications within the confluence directory

Modified files:

confluence styles aui-overrides-css.vm

confluence WEB-INF classes seraph-config.xml

confluence WEB-INF classes crowd.properties

conf server.xml

Removed files:

confluence WEB-INF lib mail-1.4.1.jar

confluence WEB-INF lib activation-1.0.2.jar

Added files:

confluence .htaccess

confluence fonts eurosti-webfont.eot

confluence fonts eurosti-webfont.svg

confluence fonts eurosti-webfont.ttf

confluence fonts eurosti-webfont.woff

confluence fonts eurostile-font.css

confluence fonts generator_generator_config.txt

confluence WEB-ING lib activation-1.0.2.jar.back

confluence WEB-ING lib crowd-integration-client-2.4.2.jar

confluence WEB-ING lib mail-1.4.1.jar.bak

lib activation-1.0.2.jar

lib mail-1.4.1.jar

Changed the Modified Files

In the aui-overrides-css.vm, I added something for line 9

In the seraph-config.xml, I commented out one line and uncommented another

In the crowd.properties, I changed the values to be what they should be

In server.xml, I changed some of the values in <context and="" added="" a="" resource="" <="" p="">

Re-Removed the Removed Files

Mail-1.4.1.jar -- copied and pasted into the root lib folder and renamed (the one in the Confluence web-inf folder) with a .bak extension

Activation.jar -- copied and pasted into the root lib folder and renamed (the one in the Confluence web-inf folder) with a .bak extension

Re-Added the Added Files

Copied and pasted from the backup, except for the .bak files and the mail-1.4.1.jar and activation.jar that I addressed in the Removed Files section

After all of this, I started the Confluence service back up. Now when I browse to our Confluence page, I get this 404 error message:

HTTP Status 404 -

type Status report


description The requested resource () is not available.

Apache Tomcat/6.0.32

Is there any way I can get some help fixing this? Do I need to roll back to the previous version?

1 answer

1 accepted


We need to look into Confluence's logs in regard of this. However I would really encourage you to raise a support ticket at https://support.atlassian.com. Please do include atlassian-confluence.log and catalina.out files that can be found in confluence-home/logs and confluence-install/logs respectively.


Atlassian Support helped me roll back successfully to 4.2.8. I will try the upgrade again in the future, preferably in a test environment.

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted Thursday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

176 views 12 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot