Universal Plugin Manager cannot connect to marketplace

I am on Confluence 4.2.4. Under Manager Add-on, I chose Confluence Update Check, version 4.3.7 and it would not work giving this error message:
An error occurred while connecting to the Atlassian Marketplace. For more information about this problem, please refer to the UPM documentation.

I followed the troubleshooting steps here with no luck:
https://confluence.atlassian.com/display/UPM/Problems+Connecting+to+the+Atlassian+Marketplace

I do not use a proxy server on campus. How can I make this work?

5 answers

1 accepted

This widget could not be displayed.

I worked with my Network Engineer in an attempt to make this work:

1. We disabled our content filter

2. We opened up our firewall completely to the IP address of the Confluence server

3. He has a monitoring box that can see all traffic to and from the internet. He did a packet capture while trying to do the check and could not see any problems via the packet capture

4. I verified the BaseURL which is http://tech.victorschools.org

Still have the same issue

Hi-- as I mentioned above, we've opened a JIRA issue for investigating this (https://ecosystem.atlassian.net/browse/UPM-3339), and it would be very helpful if you could respond to the information request there. It's not really practical to try to follow a support issue like this on the Atlassian Answers page.

The issue has been resolved, the Marketplace had one small bug that was fixed and now UPW works fine. Thanks for the quick response on this

This widget could not be displayed.

Have you tried to install the latest UPM?

This widget could not be displayed.

I am already running version 2.8.2 which is the newest. When I upgraded Confluence from 3.5.x to 4.2.4 I was able to upgrade all the plugins fine using the Update All button. What I cannot do is do the plugin check to see if I am all set to jump to 4.3.7

We've opened an issue for this: https://ecosystem.atlassian.net/browse/UPM-3339

Unfortunately, so far I've been unable to reproduce the problem using Confluence 4.2.4 and UPM 2.8.2. Some more information would be helpful - see comments on the issue.

This widget could not be displayed.

We have some reasons that can make Confluence not be able to connect to marketplace, let's analyze them:

1) Environment - The first one in most common reason is the network: A proxy or a firewall blocking the way to marketplace. Even if you are not using a proxy, is important to check if there's a firewall that can be doing this. Even when the ping works it does mean the the access is completely clear, since the ping uses the icmp protocol instead of the ip (used for usual internet connections).
So please, check with the responsible for the network security if the marketplace is blocked somehow - maybe in a black list.
Since with the upgrade of Confluence UPM was upgraded as well, is important to configure your firewall to be able to access some URLs and Ports as you can see here.

2) BaseURL - The [BaseURL in Confluence must be exactly the same URL used to access Confluence in your Browser. To do that go to Confluence Admin > General Configuration

Hope it helps!

This widget could not be displayed.

I have the same problem.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

34 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you