Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Tried to upgrade confluence from 4.03 to 4.3.2 Now site is down.

Jesse Kemp November 2, 2012

logo System Error

A system error has occurred — our apologies!

For immediate troubleshooting, consult our knowledge base for a solution.

If you would like to receive support from Atlassian's support team, ask your Confluence administrator to create a support issue on Atlassian's support system with the following information:

a description of your problem and what you were doing at the time it occurred

a copy of the error and system information found below

a copy of the application logs (if possible).

Your Confluence administrator can use the support request form to create a support ticket which will include this information.

We will respond as promptly as possible.

Thank you!

Return to site homepage…

Cause

com.atlassian.spring.container.ComponentNotFoundException: Failed to find component: No bean named 'translationModeManager' is defined

at com.atlassian.spring.container.SpringContainerContext.getComponent(SpringContainerContext.java:79)

caused by: org.springframework.beans.factory.NoSuchBeanDefinitionException: No bean named 'translationModeManager' is defined

at org.springframework.beans.factory.support.DefaultListableBeanFactory.getBeanDefinition(DefaultListableBeanFactory.java:387)

1 answer

0 votes
Septa Cahyadiputra
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
November 2, 2012

Hi there,

In order to narrow down the root cause of your issue further, you would need to review your Confluence logs which is located in <Conf_HOME_Dir>/logs/atlassian-confluence.log.

For troubleshooting purposes, you could also try the following steps on your staging environment for your upgrade test.

  1. Shutdown Confluence
  2. Revert database and home directory to pre-upgrade state
  3. Remove the following directories
    • <tt><confluence-home>/bundled-plugins</tt>
    • <tt><confluence-home>/plugins-cache</tt>
    • <tt><confluence-home>/plugins-osgi-cache</tt>
    • <tt><confluence-home>/plugins-temp</tt>
  4. Rename your<tt>atlassian-confluence.log</tt>which is located in<tt><confluence-home/logs/</tt>
  5. Restart Confluence upgrade process

To avoid any issue on your production instance during the upgrade process, we highly recommend you to create a cloned instance. Hope it helps.

Cheers,
Septa Cahyadiputra

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events