The element type "link" must be terminated by the matching end-tag "".class java.io.IOException in the jiraissues macro

When I use the JIRA issues Macro, in the table appears the following error:

Error on line 76: The element type "link" must be terminated by the matching end-tag "</link>".<br/>class java.io.IOException

Thank you for your help.

Regards

Jorge Gaston Rivainera.

11 answers

1 accepted

I had this issue too and was able to resolve it by replacing part of the link that I copied over from the XML link attribute.

The original link looked like this:
http://jira.companyname.com/jira/secure/IssueNavigator.jspa?reset=true&jqlQuery=...

And I changed it to this instead:
http://jira.companyname.com/jira/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=...

The second method was the way that we used to insert links to jira task lists into our wiki before this macro was avaialble. Hopefully this helps others as well.

I found the solution

U have to copy the XML view of the page in macro funcion in confluence

Hi, I have 4.0.5 version of Confluence and 4.4.3 version of JIRA.

Which version of JIRA/Confluence ? Applinks setup ?

It's true, thank you...

0 vote

I updated your title. It'll be more likely to be seen, plus people will find it on Google later.

0 vote

So this is a bit tricky to troubleshoot without actually playing around with the macro in a guess and check troubleshooting way. Here's what I'd do:

  1. Check to see if this is happening on all jiraissues macros (I'm guessing not?)
  2. Begin to hone in on what variables make it work or not by adding different columns to your issue navigator.
  3. If that's not changing whether its working or not, try accessing this as a different user.

Basically, something isn't closing your html tags correctly. I'm guessing this is a result of a custom field, but it also could be a one-off of the data that's returned.

If you need, open up a support ticket and give us the URL of your confluence page. Our support team can log in and take a look.

Hi Jeremy, I probe with your advice, but the Macro don't work, thank you for your help.

Do you mean the macro never works? I think the thing to do is open a support ticket at this point and we can look at the exact page.

0 vote

@citnet admin - this is ondemand.

Has anyone fixed his?

I also get this message

I found the solution

U have to copy the XML view of the page in macro funcion in confluence

I also get this. Copying the XML url didn't help.

Any solution?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted 2 hours ago in Off-topic

Miscellaneous Monday - CreatatronV3

You may remember, not so long ago, that together we invented the most evil of machines: The Destructo5000!  The effects of missing Durian rippled over nations. Complete chaos as goat chee...

36 views 2 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you