The Atlassian Plugin Exchange server is not reachable....how can i solve this error....

I'm trying to install plugins in confluence using the Universal Plugin Manager. However I get an error saying "The Atlassian Plugin Exchange server is not reachable. To avoid problems when loading this page, you can disable the connection to the Plugin Exchange server. Click here for more information..."

I've attached a copy of the logs and a screenshot of the error page. Hope someone can help me out

Thank you.

(atlassian-confluence.log)

5 answers

This widget could not be displayed.

Can you access http://marketplace.atlassian.com with your Web browser?

Per logs - Seems you are on:

  • Confluence 4.2.4
  • Universal Plugin Manager 2.0.6 (aka UPM)

Upgrade UPM to the latest - v2.3

Get it here -

https://marketplace.atlassian.com/23915

and hopefully that fixes it.

Let us know.

Ellen

This widget could not be displayed.

Hi Anand,

As describe on the ticket, please try to update your "Server Base URL" to http://localhost:8090/confluence and see how it goes.

Hope it helps.

Cheers,
Septa Cahyadiputra

This widget could not be displayed.

Hi,

We're seeing the same issue as Anand, on 2 instances of Confluence 4.2.1, running UPM 2.0.5. As well as a problem contacting the Atlassian Plugin Exchange Server the Jira gadgets we use in Confluence stopped working. Curiously, the Jira issues macro continued working fine.

I followed the advice given by Ellen and now the test instance is working normally again. For info, the version number of UPM is now 2.7.1.

Following the same approach for the production box has not worked out though. It seems that a temporary UPM self-updating plugin prevents installation of the latest version, as it is flagged as a dependency:

disableDependentPlugins Found dependent enabled plugins for uninstalled plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-selfupdater

I've tried uninstalling this manually, which goes okay, but trying to install the latest UPM then fails once more.

It's concerning that this issue has simply cropped up without any changes being instigated by ourselves.

Regards,

Charles

This widget could not be displayed.

This error is often SSL related.

You have to import marketplace's SSL certificate in your `keystore`

http://marketplace.atlassian.com:443/

See this Answer for more

This widget could not be displayed.

How to set the proxy in jira

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

137 views 16 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you