The 9443 port will not be opened, after run the

  1. I built the apache stratos finished. 
  2. When I run the, the system display that as
root@puppet:/opt/stratos-installer# sudo ./ -p "default" -s
You have selected the profile : default user provided in conf/setup.conf is root. In default profile CEP will be configured. Extracting Apache Stratos Extracting ActiveMQ /opt/stratos/apache-stratos-default /opt/stratos-installer In repository/conf/carbon.xml In repository/conf/ /opt/stratos-installer Configuring the Cloud Controller In repository/conf/cloud-controller.xml /opt/stratos/apache-stratos-default /opt/stratos-installer /opt/stratos-installer /opt/stratos/apache-stratos-default /opt/stratos-installer /opt/stratos-installer End configuring the Cloud Controller Configuring the Autoscaler /opt/stratos/apache-stratos-default /opt/stratos-installer In repository/conf/autoscaler.xml /opt/stratos-installer End configuring the Autoscaler Configuring Stratos Manager /opt/stratos/apache-stratos-default /opt/stratos-installer In repository/conf/ In repository/conf/datasources/master-datasources.xml /opt/stratos-installer Creating userstore database /opt/stratos-installer/resources /opt/stratos-installer /opt/stratos-installer End configuring the SM Configuring the Complex Event Processor /opt/stratos/apache-stratos-default /opt/stratos-installer In outputeventadaptors End configuring the Complex Event Processor /opt/stratos-installer Changing owner of /opt/stratos to root:root Apache Stratos configuration completed successfully Starting up servers. This may take time. Look at /var/log/apache-stratos/stratos-setup.log file for server startup details You can access Stratos after the server is started. ************************************************************** Management Console : **************************************************************
 3. But the 9443 port not be opened.
root@puppet:/opt/stratos-installer# netstat -anpt | grep 9443

1 answer

0 vote

Hi Di.jin, 


Can you have a look if there’s a pid file from Apache Stratos stuck in some place? Sometimes similar behaviour happens with Squid. The Squid process is stopped but there’s a pid file that wasn’t properly cleaned.


Also, check if do you have some SeLinux or AppArmor blocking it.


P.S.: I don’t believe it’s a good idea you run it as root:

Changing owner of /opt/stratos to root:root


Hope it helps.

Renato Rudnicki

Hi Renato Rudnicki, Thanks for your comments. 1. If I run the stratos demo, it's OK, the 9443 port will be lisitened. root@puppet:/opt/stratos-packs/apache-stratos-4.0.0/bin# ./ demo 2. But if I want running an real stratos, the 9443 port is closed. I don't know why. I just follow the official help documentation.

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Posted Thursday in Off-topic

Friday Fun: What's your favourite beer/drink

As a Belgian, beer-lover and home brewer, beer is one of my great passions. I love the fact that with just a few ingredients (usually just water, hop and malt) you can create so many different tastes...

301 views 38 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot