I have a problem from some days using the Tempo API.

I created a java application that send a GET request to retrive the Jira worklogs using Tempo API.

Until some days ago it worked fine.

After some update on Jira, using the same API  I receive a response like this:  ��*�@I�luLj��C����Ϥ=�J�.ĝ�:�.�tS����uk ��~�FՄa�-�^��P����������)p��4�#�0Щ����y�6.�7َS=Bק��l��eJ)ItP��6�M��~ց��d�,.�_�e���� result: �m�_K�0���%�զ�i6���>������)7��޴�X�B��%�{�շ���+g��I��N(�cd���^����r����'��$:�H��E�]��"ɲ�ᐑ�Ӝ�4O/���l+'��!#$� , and not an XML that I received before of the updates.

Now my dubious regards the compatibility between the new Jira version and the tempo API. 

The Jira version is v1000.1085.0.

The tempo api is used creating the following url: 


Can  someone give me some tips about this problem??


1 answer

The response received a gzip. Save it to a file abc.gzip and use any unzipping tool. You should have a response xml.

Hi I'll try... thank you very much!!

Yes, it worked.

Thanks very much!!

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted yesterday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

59 views 2 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot