Tempo REST API ISSUE Edited

Hi,

I have a problem from some days using the Tempo API.

I created a java application that send a GET request to retrive the Jira worklogs using Tempo API.

Until some days ago it worked fine.

After some update on Jira, using the same API  I receive a response like this:  ��*�@I�luLj��C����Ϥ=�J�.ĝ�:�.�tS����uk ��~�FՄa�-�^��P����������)p��4�#�0Щ����y�6.�7َS=Bק��l��eJ)ItP��6�M��~ց��d�,.�_�e���� result: �m�_K�0���%�զ�i6���>������)7��޴�X�B��%�{�շ���+g��I��N(�cd���^����r����'��$:�H��E�]��"ɲ�ᐑ�Ӝ�4O/���l+'��!#$� , and not an XML that I received before of the updates.

Now my dubious regards the compatibility between the new Jira version and the tempo API. 

The Jira version is v1000.1085.0.

The tempo api is used creating the following url: 

https://<my-host>/plugins/servlet/tempo-getWorklog/?tempoApiToken=<valueToken>&dateFrom=2017-06-27&dateTo=2021-12-31&format=xml&diffOnly=false&issueKey=II-11

Can  someone give me some tips about this problem??

Thanks. 

1 answer

The response received a gzip. Save it to a file abc.gzip and use any unzipping tool. You should have a response xml.

Hi I'll try... thank you very much!!

Yes, it worked.

Thanks very much!!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Friday in Europe

Venue Needed! 23rd October

Hey Everyone! Unfortunately, the venue that was hosting us on the 23rd has pulled out so we're looking for a new venue.    If anyone would have a room free that we could use on the ev...

32 views 1 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you