SourceTree: "For security reasons, you need to distribute your appcast over SSL or sign your updates. See Sparkle's documentation for more information."

I started getting this error today and not sure why. It's preventing me from connecting to our git repo. Any suggestions?

6 answers

1 accepted

Hi Karim,

A bad download can cause this to happen. We haven't had any reports of this problem as of yet. Could you try re-downloading SourceTree and trying again? If it's still problematic we can work from there.

Thanks very much in advance

Thanks Kieran, this fixed the problem.

I have the same problem, but only when I launch SourceTree from the command line (using stree).

I have tried deleting and redownloading the application, but it doesn't help. Any other suggestions?

Does the application work OK if you're not using stree?

Yes.

Something weird is going on - if I have the app running already when using stree, it seems to launch a new application instance, showing the Sparkle dialog.

I tried reinstalling the stree utility and using it directly from the application bundle without any luck. Is there anything else I can do to help find the cause?

1.7.2 fixes this. Thanks!

The problem is back (for me at least) as of the 1.9.3.1 update. I downloaded and installed freshly and that fixed it.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Friday in United States

Confluence Security Advisory

Good morning Members, Not sure if you are aware. Please read the following: https://www.icloud.com/keynote/0RyJ4VEdNUpjDpGfMhfZx9fEg#Confluence_Security_Advisor More details: https://co...

80 views 1 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you