Show Reopened Issues on Rapid Board

I tried adding new Quick Filters for issues that have been reopened (Resolved to Reopened)
http://screencast.com/t/pfA2rK7JNL

and I can see it from the Column Section http://screencast.com/t/JZHxQxulm

However
, I can't still see it in Rapid Board. The current JQL that were using is

project = "Project1" AND labels is EMPTY ORDER BY Rank ASC

I tried this

project = "Project1" AND labels is EMPTY OR status = Reopened ORDER BY Rank ASC

but still not showing. I have actually tried other filter values too on Quick Filters but no luck. Any help? Thanks!

4 answers

1 accepted

This widget could not be displayed.
Hi all. What happens if you clear the "fix version"? I believe GH uses this one for released issues. If you're able to see the issue in the rapidboard after clearing the value you may need to add this as a postfunction in your "reopen" transition as well

You got it! I cleared the Fix Version/s: Re. The addition of value in postfunction, can I edit the GreenHopper Simplified Workflow for this? Or should I create a new workflow?

@Renjith. As always, thank you for your help.

Hi liza. I never used GH simplified flows but i assume they're editable too
If this situation appears in simplified workflows i believe atlassian should fix it in the next GH release. Please raise a support request like renjith already suggested.

Wow Faysal, that was a good one.

But I still do not understand as the Rapid Boards do not use fixVersion for deciding anything on the Planning board (it checks only for Resolved or not). Am a bit confused now.

Thats confusing me too. But somehow its clear and logical too. As you add a fixVersion to an issue it says that there is an existing release this issue belongs to. So why should GH dive into historical stuff when it's main focus is on current and upcoming work processes. I think the simplified workflow should really be modified so that all scenarios are working fine.

Will get this verified.

OMG ! I was thinking all these while that @liza28 was having a scrum board.

Of course Kanban boards will not shows things which have a fixVersion, as that is the sub-query set in the Kanban board configuration to filtering completed issues.

@Renijth. Sorry I was not able to tell you the kind of board I'm using. Yes, it's a Kanban.

This widget could not be displayed.

While the answer to this appears to be that the workflow that is opening the issue from Closed to Reopened seems to be not setting the Resolution back to empty in the Post Function.

Can you post a screenshot of one of the Reopened issues?

Hi! Renjith. Thanks again for sticking with me. See http://screencast.com/t/VLLUatwXkuye

and this is the workflow screenshot http://screencast.com/t/F8lnWx6wIwx.

Sorry, can you also give your board filter JQL?

Hi! DanielWester and Renijth. Our column mapping is here - http://screencast.com/t/8aDPbKJgK

Is that correct?

@Daniel. When I try to use a filter with status "Reopened" the issue shows on Issue Navigator but not on Rapid Board

project = "VA Project" AND labels is EMPTY ORDER BY Rank ASC

Does it show up when you got the Issue Navigator for the JQL? If it shows up there - then it's a mapping issue inside the Rapid Board (I've seen ranking blocking things).

That all looks right to me.

Suggestions :

  1. According to that screenshot - you only have one item in the reopened state? I'm wondering if you might need to rank it higher (in Jira - under More actions).
  2. Can you go to the Issue and navigate to the issue on the rapid board from the Agile tab?

That looks fine :(

Can you reindex JIRA and see if issues are appearing? If yes, I suspect some problem in your workflow while reopening by which it is throwing and error before the issue reindex condition is being called.

Hi! DanielWester.

1. how can I do that?

2. yes I can.

@Renijth. I have just re-index and jira. The reopened issues are still not showing on Rapid Board.

by the way, we're Using GreenHopper Simplified Workflow. Does it affect the statuses?

This widget could not be displayed.

If you skip the RapidBoards and go to the filter's rapid board - does it show up there? I would suggest troubleshooting from there first. If it appears there then head back to the RapidBoard

This widget could not be displayed.
May be its time to raise a support request with Atlassian with your xml backup data. Refer to this post while creating the ticket.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published yesterday in Marketplace Apps

The 7 hacks of highly successful automation

...there's anything I've learnt from working, it's that people are lazy! No offense to anyone reading this, but it's true and we can all admit it. The easier you make something for someone, the more...

92 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you