Search Result Returns Wrong Assignee

I have an ongoing issue where Jira returns the wrong Assignee when i search for issues using the assigned to me search filter

Refer to the first screenshot, the search result indicates the assignee as test-manager.

However this is incorrect as it should display the assignee as myself (Jack Lim). (Refer to the second screenshot)

I believe this to be a bug and it's affecting the ability for users to make use of the issues assigned to me search filter.

3 answers

0 vote
Daryl Chuah Atlassian Team Jan 16, 2013

Hi Jack

I am not able to view the screenshot. By the way, have you try reindexing : ?


The re index seemed to fix the issue, however it requires me to manually trigger re-index (as you mentioned) for it to acutally work.

Is there anyway for it to be done automatically?, it doesnt seem to make sense for me to perform a reindex every few hours..

I met the same problem

Please check your workflow Settings

Post Function-->Re-index an issue to keep indexes in sync with the database.

Assign the issue to the XXX condition Should Before Re-index

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Posted Thursday in Off-topic

Friday Fun: What's your favourite beer/drink

As a Belgian, beer-lover and home brewer, beer is one of my great passions. I love the fact that with just a few ingredients (usually just water, hop and malt) you can create so many different tastes...

291 views 38 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot