Public key error in Application Links

Hi,

I am trying to get Jira gadgets onto Liferay Portal. But I am facing issues in Jira accepting Public key.

I generated public key using Puttygen and saved the public key.

In Jira - Opened Jira -> Application Links -> created new Generic Application -> Incoming Authentication
consumer key - www.liferay.com
consumer Name - Liferay
Public key - gave the public key text in public key file
callback - callback as mentioned in Liferay opensocial gadget

When I tried to save the settings, I get an error in Jira "Must be a valid public key. java.security.InvalidKeyException: invalid key format".

Where am I going wrong? How are the public and private key generated?

Regards,

Anantha

3 answers

Hi Anantha, maybe we can put our pieces of the puzzle together ;). i have already managed to import the public key in Jira, just see https://answers.atlassian.com/questions/17240/consuming-jira-gadget-in-liferay But i have absolutely no idea, where from Liferray gets it's private key ... Maybe you can help me in this regard

Hi Dieter,

We are sailing in the same boat. Dejuknow has answered our queries in this forum http://stackoverflow.com/questions/8491844/jira-liferay-integration but still unable to succeed in integrating.

I tried to reach him in the same thread but it was deleted. Let me try my luck. I generated my public key using keytool and now that text area is greyed out in Application Links in Jira. Now I have to work on the other side Liferay for this integration. Only public key is generated and have no idea of private key. If I succeed I will let you know through this thread.

Regards,

Anantha

Hi Anantha,, that looks promising. I also had managed to install the public key on Jira side but never knew where to put the private key on the Liferay side. Will try to let our Liferay admin install the fix and try again. Thanks once more!

Hey Guys,

Did anyone able to resolve this issue? Any luck in getting OpenSocial gadget portlel work in liferay connecting Jira.

I am facing the same issue but not able to fix it.

Any help is appreciated.

Thanks

can you post answer if you fixed it?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

123 views 6 8
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you