Problem updating plugins from UPM page.

Having problems updating plugins frum the UPM page. Only works about 20% of the time.

The message for the last plugin I tried to update is:

Problem accessing add-on file at

I'm running JIRA 5.1.7, UPM version 2.9.1

7 answers

1 accepted

We think our problem may be related in part to our firewall rules. So I'll just keep working with our helpdesk to get this working.

I found a solution for my problem. It turned out to be the SSL certificate of CloudFront.

According to this documentation the Universal Plugin Manager needs access to * and to get Plugins and Updates from the Market Place. Since everything else worked (DNS, wget to both addresses) this was the only thing left I could think of.

Following this article I used portecle to download the SSL certificate of and add it as a trusted certificate to the systemwide certification store (/etc/ssl/certs/java/cacerts in my case). After a restart of Confluence (I had the problem with all Atlassian Tools on this server instance) it worked flawlessly.

Downside: The certificate expires this year on November 14th, so when this happens I'll try to get the chain right.

Commands to easily add the certificates to cacerts:

echo -n | openssl s_client -connect | sed -ne '/-BEGIN CERTIFICATE-/,/-END CERTIFICATE-/p' > atlassian.cert
sudo keytool -import -alias -file atlassian.cert -keystore /usr/lib/jvm/java-7-oracle/jre/lib/security/cacerts

Make sure the path to cacerts matches to your installation. 

Thanks so much for posting this Gerald. Very helpful! Found myself in the same boat and your solution fixed it.

Hi there,

Did you try to download this plugin's .jar file and upload it into JIRA?

To do this, just click on "upload file" in the "Manage Add-Ons" tab and try to perform the upgrade like this.

Also, there is the other possiblity which is to do the "manual" procedure. To do this method, just shutdown JIRA, browse through <<JIRA_HOME>>/plugins and look for the .jar file of this plugin inside the installed-plugins folder. Completely delete this .jar file and then paste the downloaded version inside this folder (so you can have the latest version installed in JIRA without passing by the web upgrade process).

A reindex may be needed after the second procedure.

I hope this helps!


It does work manually, but I'd like to know if there is a way to fix it so it works the way it should (via UPM). It's a lot faster updating plugins via the UPM than it is doing it manually as I don't have to stop/start services when I do it via UPM.

Thanks. I’ve forwarded your fix to our IT people to see if this is what they did OR in case your solution was better than theirs.

I have the same problem. I can download the file from the link provided and install it manually, it's just the automatic update that doesn't work.

Our problem was with out firewall. Our IT people fixed it.

So has this cropped up as an issue for you again Gerald? I tried your solution below and I assumed it would fix the issue, but actually it did not. Now I'm wondering if it's just a temporary problem Atlassian is having.

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

47 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot