Problem installing stash

I'm stuck in the last step, when I try to open http://Localhost:7990 I got "page not found" Can you help me?

5 answers

1 accepted

How can I close this Question???

1 vote

Can you look at the logs and see if there were any error during startup? Did you define a Stash home? If so, look at atlassian-stash.log under log folder. If you can't find it, look at catalina.out under Stash_Install_Dir/logs folder.

thanks for your answer,
my log folder is empty
my stash_home is defined
when I run "bin\start-stash.bat" I got to run STASH in the foreground, start the server with start-stash.bat /fg

What do you see in catalina.out?

I don't have that file, the logs folder is empty

Seems Stash never got started then. Can you try without /fg and see what happens?

Did you set JAVA_HOME?

Yes I run without /fg and I got the message: " run STASH in the foreground, start the server with start-stash.bat /fg" the I run with /fg and I got no message but it still doesn't work

Yes I do set JAVA_HOME in my Enviroment variables, do I have to set it somewhere else?

Hi Alcides,

If you're still stuck you might want to raise a support ticket so that our support team can help.

http://support.atlassian.com/

Having JAVA_HOME in your environment should be enough. Is there _any_ output from running with '/fg', or does it look like the screenshot in the issue STASH-2822?

Charles

Thank's I'll raise a Ticket about your question, when I run with '/fg' got no message output, and it looks like the screenshot
thank, do I have to change something in the file "setenv.bat" ?

Hi Alcides,

Assuming JAVA_HOME is set, or running 'set JAVA_HOME=c:\Your\Java' should be enough. If you edit the setenv.bat and change 'echo off' to 'echo on' that might give you more of an idea of why it isn't working. You might want to attach your JAVA_HOME variable as well as the output of running the script with echoing to the support ticket and here so we can help further.

Charles

Hi Alcides,

I'm afraid we might need more than that. Is there anything in the $STASH_HOME/log/atlassian-stash.log file or the console?

If you started from the standard Stash distribution the above URL should work, but if you're using our developer tools it might need a '/stash' at the end of that URL. From the output of my console:

[INFO] [talledLocalContainer] Tomcat 7.x started on port [7990]
[INFO] stash started successfully in 186s at http://hostname:7990/stash

Charles

neither with http://hostname:7990/stash work

when I run "bin\start-stash.bat" I got to run STASH in the foreground, start the server with start-stash.bat /fg

does this means that the installation is not right
I have a windows 7 32 bits

neither with http://hostname:7990/stash work

when I run "bin\start-stash.bat" I got to run STASH in the foreground, start the server with start-stash.bat /fg

does this means that the installation is not right
I have a windows 7 32 bits

The problem is solved, it seems that was my computer, becouse I've installed in 2 differents computers with no problem

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Thursday in Off-topic

Friday Fun: Magic Eyes

...staring into the background. Once the image pops out in 3D, you can look around the picture and enjoy. If you will see if you are a true illusion master! :) You did it? :) Wow! Awesome! As a bonus...

426 views 79 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you