Pie Chart Gadget displaying an error but should not be

I've been configuring a few different issue types, and all of a sudden I saw that my pie chart for the project displayed the following error when using the Statistic type: Components:

An internal server error occurred when requesting resource /rest/gadget/1.0/piechart/generate.

Clicking on the error hyperlink produced the following error:

{errorMessages: ,errors: {field:projectOrFilterId,error:gadget.common.required.query} }

My project has 3 issue types, and component is populated for all of them. I don't see why an error is being produced when all the data exists. When I choose other statistic types such as assignee, the data displays fine.

2 answers

1 accepted

This widget could not be displayed.

Received answer elsewhere, which was to reindex. This resolved the issue.

This widget could not be displayed.
Boris Berenberg Community Champion Dec 01, 2012

Hey Manohar,

Did you remember to specify a filter such a project or multiple projects or a JQL query? You can not leave the query field empty and have JIRA look at everything.

Cheers,
Boris

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 5 hours ago in Featured Groups

Hi! I'm Cameron Deatsch, Head of Server at Atlassian and I'm hosting an AMA next week.

Hey team! I'm Cameron Deatsch, Head of Server at Atlassian. I'll be hosting an AMA over in our Questions section of the Community next Monday, so shoot me your questions, upvote others' question...

24 views 0 2
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you