One-click Automatic Clover integration in Bamboo does not produce a report

We are attempting to integrate Clover code coverage in the bamboo builds of many projects within our organization. We have checked the box for the automatic clover integration in projects that are running ant, and projects that are running maven. The builds run successfully but no report is generated. The logs contains the line Failed to execute plugin 'Clover Results Collector' with error: No file matches the specified pattern:clover/**/clover.xml in data/atlassian/bamboo/xml-data/build-dir/PROJECT1-APP-JOB1 . There isn't anything else in the instructions, so we are not sure what the problem is. Please help point us in the right direction.

1 answer

I also get this error

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

122 views 6 8
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you