One-click Automatic Clover integration in Bamboo does not produce a report

We are attempting to integrate Clover code coverage in the bamboo builds of many projects within our organization. We have checked the box for the automatic clover integration in projects that are running ant, and projects that are running maven. The builds run successfully but no report is generated. The logs contains the line Failed to execute plugin 'Clover Results Collector' with error: No file matches the specified pattern:clover/**/clover.xml in data/atlassian/bamboo/xml-data/build-dir/PROJECT1-APP-JOB1 . There isn't anything else in the instructions, so we are not sure what the problem is. Please help point us in the right direction.

1 answer

I also get this error

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Thursday in Off-topic

Friday Fun: Magic Eyes

...staring into the background. Once the image pops out in 3D, you can look around the picture and enjoy. If you will see if you are a true illusion master! :) You did it? :) Wow! Awesome! As a bonus...

415 views 79 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you