Not able to preserve the reverse proxy URL, redirecting to the application URL Edited

Hello there!

I am new to this forum, and seeking help from you guys.

This is the configuration,

 

Actual code is this,

    LoadModule ssl_module modules/mod_ssl.so
Listen 443
SSLPassPhraseDialog exec:/opt/testlab/pki/keystore/pass-script.sh
NameVirtualHost *:443
<VirtualHost *:443>
     ServerName frafahadooappd5.de.cd.com
        SSLEngine on
        SSLCertificateFile /opt/testlab/pki/publicCertificates/host_crt.pem
        SSLCertificateKeyFile /opt/testlab/pki/keystore/host_key.pem
        SSLCertificateChainFile /opt/testlab/pki/publicCertificates/chain_crt.pem
        SSLProxyEngine On
        ProxyPreserveHost Off -> if I set this to on, the reverse proxy is not working, not sure why?
     ProxyPass /  "https://dev.cdsw.abc.intranet.cd.com/"
     ProxyPassReverse / "https://dev.cdsw.abc.intranet.cd.com/"
     ProxyPassReverseCookieDomain "dev.cdsw.abc.intranet.cd.com" "frafahadooappd5.de.cd.com"
</VirtualHost>

Actually, this works fine as long as I click on options like Jobs, Options after login, when I click one another link on the same page, it goes back to the application URL, which is not supposed to be the case. It should still remain on the same URL https://frafahadooappd5.de.cd.com/, but instead it goes to the application URL https://dev.cdsw.abc.intranet.cd.com/vijay/testpython-oracle and lands up in this link https://dev.cdsw.abc.intranet.cd.com/login?next=%2Fvijay%2Ftestpython-oracleasking me to login back to the application. How do I restrict it?

Actual reverse proxy URL : https://frafahadooappd5.de.cd.com/

Original application URL : https://dev.cdsw.abc.intranet.cd.com

Behaviour of URL when I goto links on the web portal after the login, when I click on options and administration, URL remains same as below: https://frafahadooappd5.de.cd.com/jobs and https://frafahadooappd5.de.cd.com/administration

However, when I click one another link on the same page, it goes back to the application URL, which is supposed to be hid by reverse proxy.

 

0 answers

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published yesterday in Marketplace Apps

The 7 hacks of highly successful automation

...there's anything I've learnt from working, it's that people are lazy! No offense to anyone reading this, but it's true and we can all admit it. The easier you make something for someone, the more...

94 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you