Not able to login after upgrading from 3.2 to 3.5.1

I did the upgrade from confluence 3.2-std to 3.5-std. After following all recommended steps for upgrade including mysql InnoDb changes and password changes the upgrade went fine. However, now when I try to login as admin. After entering the password it again comes back to login screen. I believe its not even going to authentication phase as I am not getting any login failed kind of error.

I did try to reset the admin password to admin using the steps but nothing seems to work. Everything was working before upgrade.

I am following below steps for upgrade. I am using centos 5.

Shutdown the confluence.

Take backup of the confluence data directory and the mysql dump.

tar -czvf confluence-data.tar.gz /usr/local/confluence-data/*

###backup: #

mysqldump -umyname -p confluence > confluence_dump.sql


mysql -umyname -p confluence < confluence_dump.sql

### Find and replace MyISAM to InnoDb in the mysql dump script and save as confluence_dump_innodb.sql

## goto shell

mysql -umedaccess -p confluence < confluence_dump_innodb.sql

Change the mysql setting.





service mysqld restart

Update the license key if it has expired. To check it Confluence Admin -> license status

Download confluence 3.5 standalone zip file unzip it.

Change the data directory in file /usr/local/confluence/confluence/WEB-INF/classes/

confluence.home = /usr/local/confluence-data

Copy the osuser.xml file from previous installation to /usr/local/confluence/confluence/WEB-INF/classes.

chown -R confluence.confluence /usr/local/confluence

Start confluence.

3 answers

1 accepted

It turned out to be Browser issue and cleaned everything and tried it worked.

Hi, can you see if there are any errors/warnings in the logs? Are you using LDAP or local users? The way that LDAP users login has definitely changed.

Make sure you have followed all the steps in and any other previous upgrade notes from 3.5 to 3.2.

No I am not using any LDAP. Moreover, Interesting fact is my upgrade from 3.2 to 3.5 worked on my test environment after fixing the mysql issues. And when I tried it on live system I ended up with this new problem. So now I am again doing a complete upgrade on test environment before I try it on the live once again.

How about try to access Confluence from another browser and login again. Just to isolate if it could be due to session issue.

Well it works on Chrome and firefox is giving issues.

I cleaned up browser stuff and its working on firefox too. Thanks

Suggest an answer

Log in or Join to answer
Community showcase
Jason Wong
Published yesterday in Agility Beta

Welcome to agility

Every team in the world is unique, and so   Atlassian believes   that each and every team's best way of working  needs to  be molded to their unique circumstances  – ...

297 views 6 15
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot