[Noob] "port 22: Connection refused." Problems to use git under proxy.

Hello everyone.

I am at client s location and I can t acces to my repository.

The problem will be with ssh connections.

The client s connection has a proxy and I don t know how to configure it in git.

What can I do?

Thanks

1 answer

This widget could not be displayed.

Hi Cézar,

It seems the port 22 is not accessible and/or you don't have ssh daemon installed/running.

Could you have a look if port 22 is open, please? As well as that, have a look if the ssh daemon is currenctly running. If not, please start it and try to run your ssh request once again, please.

ssh has 2 main components:

  1. ssh : The command we use to connect to remote machines - the client.
  2. sshd : The daemon that is running on the server and allows clients to connect to the server.

ssh is pre-enabled on Linux, but in order to start sshd daemon, we need to install ssh first. Use this command to do that:

$ sudo apt-get install ssh

This will install ssh on your machine. In order to check if ssh is setup properly do this:

$ which ssh

It will throw this line on your terminal
/usr/bin/ssh

$ which sshd

It will throw this line on your terminal
/usr/bin/sshd

Kind regards,
Rafael

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in United States

Local Atlassian Research Workshop opportunity on Sep. 28th

We're looking for participants for another workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sh...

52 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you