No draft workflow was found for "XXXXX" exception

HongChao Song June 11, 2017

Hi,

I found No draft workflow was found for "XXXXX" exception when checking system log, and have ask for some clue in the open issues list but no result.

Could somebody please tell me how to deal with this situation, ignore?

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Answer accepted
Jeremy M
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June 11, 2017

Dear HongChao,

Indeed a known problem within certain versions of JIRA;

You are not being directed to a 404 page are you?

I have seen that problem earlier and see documentation here;

https://confluence.atlassian.com/jirakb/publishing-a-draft-workflow-in-jira-leads-to-a-404-error-page-828798727.html

Cause

It's uncertain what causes this to happen, but basically JIRA needs to rebuild certain work files in the $JIRA Install/work directory

Resolution

Clear the contents of the work directory and restart JIRA

  1. Stop JIRA
  2. Remove the contents of the JIRA Install > work directory
    (warning)Do not delete the entire directory itself, just the contents
  3. Restart JIRA

Also in this Atlassian Support Ticket it is being tracked;

https://jira.atlassian.com/browse/JRASERVER-38221

You can see that people are posting in 2017 that this error is again occurring. It is best to track that issue for now and ignore the message if nobody gets a 404 error.

Friendly Regards,

Jeremy Mooiman

HongChao Song June 12, 2017

I will try, thanks.

Jeremy M
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June 12, 2017

Feel free to ''accept'' this answer if you deem it worthy enough.

Thanks!

HongChao Song June 12, 2017

we installed it by xxx.bin file, as following:

123.PNG

So what 's  JIRA Install > work directory refer to?It means reinstall it?

HongChao Song June 12, 2017

123.PNGattach screenshot again

Jeremy M
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June 12, 2017

Dear HongChao,

That is the correct directory. You can see the ''Work'' directory.

Do not delete the map ''Work'' itself but only the content in the ''Work'' map.

  1. So first STOP Jira,
  2. Then delete the contents in the ''Work'' map.
  3. then START Jira.

This way Jira can remake the correct files.

Friendly Regards,

Jeremy

HongChao Song June 13, 2017

thanks for your support,:)

Jeremy M
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June 15, 2017

Dear HongChao,

No problems! :)

Can you ''Accept'' my answer?

Friendly Regards,

Jeremy

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