Need atlassian-jira-6.1.6.jar for plugin compilation

Hello,

I am migrating a custom plugin from JIRA 5.1 to JIRA 6.1.6. I have udpated my pom.xml to jave jira.version = 6.1.6. While compiling the plugin, I get an error saying the atlassian-jira-6.1.6.jar cannot be downloaded.

Embedded error: Missing: 1) com.atlassian.jira:atlassian-jira:jar:6.1.6 Try downloading the file manually from the project website.

Also, this location https://maven.atlassian.com/repository/public/com/atlassian/jira/atlassian-jira/does not contain 6.1 related jars.

Has the JIRA repository changed?

Thanks for you help.

1 answer

The libraries have changed, now you should use the API:

<dependency>

<groupId>com.atlassian.jira</groupId>

<artifactId>jira-api</artifactId>

<version>${jira.version}</version>

<scope>provided</scope>

</dependency>

And only if needed, the core:

<dependency>

<groupId>com.atlassian.jira</groupId>

<artifactId>jira-core</artifactId>

<version>${jira.version}</version>

<scope>provided</scope>

</dependency>

Browse for versions @ https://maven.atlassian.com/content/groups/public/com/atlassian

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in United States

Topic Tuesday: What's your favorite topic?

Good morning All, Our goal is to get you into the habit of while enjoying your favorite morning drink you are checking the NOVA "space" for topics and comments. Your input is really needed and...

68 views 4 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you