Main Class not found when running database access speed test

This question is in reference to Atlassian Documentation: Testing database access speed


when trying to run the test from this article under Ubuntu i run into the following problem:


/opt/atlassian/jira/jre/bin/java -cp /data/AS-4339/atlassian-log-analysis-0.1.1.jar:/opt/atlassian/jira/lib/postgresql-9.1-903.jdbc4-atlassian-hosted.jar \
com.atlassian.util.benchmark.JIRASQLPerformance \
jira asdfasdfasfas \
'jdbc:postgresql://localhost:5432/jiradb' org.postgresql.Driver

when i run it i get 

Fehler: Hauptklasse com.atlassian.util.benchmark.JIRASQLPerformance jira konnte nicht gefunden oder geladen werden

roughly translated:

Errror: Main class  com.atlassian.util.benchmark.JIRASQLPerformance jira could not ne found or loaded

java seems to regard the parameter for the database user name as part of the classname (marked in bold).

how do i fix that?

1 answer

1 accepted

Okay sometimes you just have to replace the spaces you copied from atlassians article manually.

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted yesterday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

153 views 12 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot