Macro hides other content


I developed a macro for confluence. The macro works as expected but the problem is that as soon as I include it into a page, all other content gets invisible. When I switch back to edit mode, the other content is still there, so it does not get deleted.
Does anyone know a solution for this problem?

Thanks in advance.

3 answers

I've reduced the output of the plugin to a minimum ("<div id='foo'>baa</div>").

The problem still occurs.

See also

Hi Sven,

Please double check if you are closing correctly all tags. If you will be sure about that then you need to check if you are not using any other macro that canoot be used inside other one. Verify also the source code after saving and check how it looks on other browsers.

I hope that will help.

Best Regards,


The problem was, that the Mainview-Template included html-, head- and body-tag.

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted Thursday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

174 views 12 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot