MSTest Runner Doesn't Work

We added an MSTest Runner task to our job but it always errors out because it can't find mstest.exe. Here's the error in the log:

20-Dec-2012 07:14:18 Error occurred while running Task '(2)'. This build will fail. Caused by:

20-Dec-2012 07:14:18 java.lang.IllegalArgumentException: mstest.exe cannot be found

I've gone into the task configuration screen and altered the executable path to be C: Program Files (x86) Microsoft Visual Studio 11.0 Common7 IDE MSTest.exe. I've tried it with both the quotes and without the quotes.


3 answers


Just add MSTest.exe as an executable capability for your Bamboo remote agent and set the task to execute this executable.

Lucas Lima

Similar problem - and solution above does not work.

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted yesterday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

49 views 2 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot