MSTest Runner Doesn't Work

We added an MSTest Runner task to our job but it always errors out because it can't find mstest.exe. Here's the error in the log:

20-Dec-2012 07:14:18 Error occurred while running Task '(2)'. This build will fail. Caused by:

20-Dec-2012 07:14:18 java.lang.IllegalArgumentException: mstest.exe cannot be found

I've gone into the task configuration screen and altered the executable path to be C: Program Files (x86) Microsoft Visual Studio 11.0 Common7 IDE MSTest.exe. I've tried it with both the quotes and without the quotes.

Help!!??

3 answers

Hi,

Just add MSTest.exe as an executable capability for your Bamboo remote agent and set the task to execute this executable.

Lucas Lima

Similar problem - and solution above does not work.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Uncategorized

Friday fun: how many celebrates Midsummer holiday or is this a Swedish tradition only?

Any other country that celebrates Midsummer holiday (this friday 22 June)?  

44 views 3 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you