ListOfStrings not working

I am trying to use this in a query similar to

WHERE FieldType IN (:Type) following the available pocketquery documentation

but it is not working... I have tried everything with comas, quotes, etc... and of course declared Type=ListOfStrings in the query "designer"...

The field FieldType has the values "I", "R" or "CO"... and I've tried in the case in the broser with 'I,R', 'I','R'... well, everything... and it is not working...

What I am not doing correctly?

Thanks in advance

 

2 answers

1 accepted

Hi Felix!

In fact I solved my "problem" just after publising the post... I tried to find it to reply but I did not succeded...

It's now working well!!!

Thanks

Glad to hear that! Could you accept my answer?

Hi Cuto!

Let's try this way: I'll provide you my example which works perfectly. My environment: MySQL, PQ 2.0.5, Confluence 5.9.5. Please check with this first if there's something wrong with your configuration...

My query:

SELECT Name, Population
FROM Country
WHERE Name IN (:Countries)

Parameter types: Countries=ListOfStrings

In the macro, I pass this as parameter "Countries": Sweden,Norway,Finland

Everything else I leave default.

Does this differ to your case anyhow?

Regards, Felix (Scandio)

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Marketplace Apps

Tips on how to choose the best estimation method for your planning

Planning and grooming sessions all come with their own sets of rules. Team members meet to estimate stories or other work items, all according to an agreed-upon process. And with every session comes ...

67 views 0 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you