LDAP Login failing if £ symbol present in password

I am trying to connect to LDAP from my Java Application. It is working fine until now. But the customer has reported an issue saying he gets an error while logging into the application if "£" Symbol is present in the password.

I am able to replicate the issue locally. When the password field has the "£" Symbol then the LDAPException is thrown and the log file shows the below error:

"LDAP error 49 - AcceptSecurityContext error, data 52e -

I am using the ldapjdk.jar file in my application. Any help would be highly appreciated.

Thanks and regards,
Nitin Avula.

1 answer

Hi Nitin, do you see this problem only in your JAVA Application, or it also occurs in Atlassian products? What relation your application has with Atlassian products, do you have any kind of integration in place? In case yes, could you give us some more details?

Cheers

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

51 views 2 4
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you