It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira plugin development problem with eclipse

I'm trying to write my first jira plugin but a get an error in eclipse (as far as I can tell property configured https://developer.atlassian.com/display/DOCS/Set+Up+the+Eclipse+IDE+for+Windows)

I get some resolve errors

The import com.atlassian.jira.issue.views cannot be resolved

The import com.atlassian.jira.util.JiraVelocityUtils cannot be resolved

Any Idea why?

1 answer

1 accepted

0 votes
Answer accepted

Do you have the jira-core dependency enabled. It is disabled by default in the pom.xml and JiraVelocityUtils is in that package.

I did a atlas-mvn eclispe:clean eclipse:eclipse as well and everything worked

tahnks

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted yesterday in Off-topic

Miscellaneous Monday - Where it all started.

Happy Monday everyone! If you're anything like me, you tend to think a lot about what the future looks like. What are my kids up to in 15 years? Have we solved for climate change? How could TVs poss...

129 views 12 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you