Jira and Stash integration break after enabling SSL on both

I was able to establish integration between Jira and Stash prior to configuring SSL but it now it has trouble seeing each application in the application links. I have HTTPS redirect setup and keep receiving a "No Response was received from the URL you entered - it may not be valid". If i try to push through by referencing the HTTP URL, i'll receive the error "it has not been possible to retrieve the required information from [URL]. Therefore the link cannot be created"

Should the applications be communicating of HTTP and not HTTPS?

BTW: The two applications on currently on the same server and using different ports. They work fine individually. This is a test environment.

thanks!

4 answers

Hi Steve,

Does the same problem persists after recreating the Application Links?

If recreating it does not solve the issue, which steps did you do to enable SSL? Have you changed the option (on web.xml) to not allow the HTTP to work? Or are you able to access your Jira and Stash with HTTP too?

Hi Bruna,

Thanks for the quick reply. I have tried recreating the Application Links from scratch with no success. I have it currently setup to rediract all HTTP requests to HTTPS so technically there will be no way to access the application via HTTP. I can try to disable the require redirect and allow both HTTP and HTTPS access but prefer to always use HTTPS.

Hi Bruna,

Thanks for the quick reply. I have tried recreating the Application Links from scratch with no success. I have it currently setup to rediract all HTTP requests to HTTPS so technically there will be no way to access the application via HTTP. I can try to disable the require redirect and allow both HTTP and HTTPS access but prefer to always use HTTPS.

0 vote

Ensure you have imported the SSL certificate of JIRA into Stash server keystore/truststore, and that of Stash as well into JIRA's keystore, to ensure both applications can communicate securely. See https://confluence.atlassian.com/display/JIRA/Connecting+to+SSL+services

I'm actually hosting Jira and Stash on the same server and using the same certificate and keystore. This appears to be working individually but not sure how it affects communication between the two apps.

I still have not gotten anywhere with this. Do you believe that this is an issues since i'm running the two applications on the same server and using the same keystore? This is a test environment that we're deploying for pilot of the Atlassian tool suite. thanks

0 vote
Tim Evans Atlassian Team Jan 01, 2015

It sounds like you may be encountering this bug: https://jira.atlassian.com/browse/JRA-40968

  • The bug contains workarounds for this issue

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published yesterday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

54 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you