Jira and Bamboo Application Link fails

I am setting up application links between jira and bamboo. Both are on tomcat and are reverse proxied. When I try the application link in Jira I get that bamboo could not respond to establish the reverse link. When looking at the jira log I get:

2011-09-19 10:30:13,016 http-8080-26 WARN Michael Bode 630x163448x1 sewoge /rest/applinks/1.0/permission/reciprocate-application-delete/ab7acf35-b2e0-3026-9b1e-4542f577486d [apache.commons.httpclient.HttpMethodDirector] Unable to respond to any of these challenges: {oauth=OAuth realm="https%3A%2F%2Fbamboo.domain.com"}
2011-09-19 10:30:13,022 http-8080-26 WARN Michael Bode 630x163448x1 sewoge /rest/applinks/1.0/permission/reciprocate-application-delete/ab7acf35-b2e0-3026-9b1e-4542f577486d [apache.commons.httpclient.HttpMethodBase] Going to buffer response body of large or unknown size. Using getResponseBodyAsStream instead is recommended.
2011-09-19 10:30:13,023 http-8080-26 WARN Michael Bode 630x163448x1 sewoge /rest/applinks/1.0/permission/reciprocate-application-delete/ab7acf35-b2e0-3026-9b1e-4542f577486d [applinks.core.rest.PermissionResource] Authentication failed for application link Developer Network (ab7acf35-b2e0-3026-9b1e-4542f577486d) https://bamboo.domain.com com.atlassian.applinks.application.bamboo.BambooApplicationTypeImpl@12a1ccbc. Response headers: {WWW-Authenticate=OAuth realm="https%3A%2F%2Fbamboo.bisimulations.com", Date=Mon, 19 Sep 2011 08:25:14 GMT, Transfer-Encoding=chunked, Set-Cookie=SERVERID=bamboo; path=/, X-Seraph-Trusted-App-Error=APP_UNKNOWN;   Unknown Application: {0};       ["jira:14048463"], X-Seraph-Trusted-App-Status=ERROR, Connection=close, Content-Type=application/json, Server=Apache-Coyote/1.1, Cache-Control=no-transform} body: {"status-code":401,"message":"Client must be authenticated to access this resource."}
Anyone have a reverse proxy setup with this working?

1 answer

I am using an apache reverse proxy betwen all the tools and Bamboo is the only one that fails. I have an open defect with the dev team because despite all OAuth being removed, Bamboo still tries to use a non-existent oatuh token for authenitcation.

Just for giggles try "basic auth" after authenticating to both systems as the same user. That allows gagets to work for me as a proof that outh was the root cause, and not my proxy.

I have tried that but it still doesn't reach. I even set bamboo to reach jira direct via IP:8080 with all auth types. It still cannot reach, though via browser I can. I am running jira and bamboo on SSL rever proxy and looking in the log I found:

[JiraRemoteIssueManagerImpl]com.atlassian.sal.api.net.ResponseException: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: subject/issuer name chaining check failed

But the SSL chain is correct and I even imported the cert into the java keystore on bamboo. All to no avail. I don't think the SSL comes into play as the underlying issue, since I cannot even get bamboo to reach IP:8080 but is also interesting.

So basically Jira can see bamboo, but bamboo cannot see jira - though both are setup the same way behind proxies.

FWIW: I've fought this same PKIX/SSL problem pretty frequently. One thing we ran into was when we used the newish Jira installer, it embedded it's own JRE. You need to make sure all of your JRE's/JDKS's you are using have the correct keystore. Essentially make sure your using the Java you think you are. It sure sounds simple, but I blew a couple hours on it.

I ran into this between Jira and Confluence, and have never used Bamboo, so YMMV.

That is a good thought, however I am sure about the java used and the issue is on the bamboo side. I am using Tomcat WAR instead of jetty as well since you cannot reverse proxy with jetty and bamboo very well. See my other topic: https://answers.atlassian.com/questions/3097/bamboo-running-behind-a-reverse-proxy

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

171 views 3 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot