Jira-administrator can't create a project

I am not sure when this started but people in the jira-administrator group can no longer create projects. This means we can't create projects at all right now in Jira. I saw some reports of this in other questions but they were all using OnDemand, we aren't.

If jira-administrator group can't create projects, who can create projects in Jira now?

10 answers

1 accepted

This widget could not be displayed.

It turns out the project was actually being created, the problem was the administrator creating the project had no Browse Project permission on the created project. So the permission violation was occuring when they were being redirected to the project page after the project was being created. This really seems like a catch-22.

My solution was to give Project Lead Browse project permissions on our default permission scheme. This assumes the person creating the project makes themselves project lead and uses the default permission scheme. Otherwise they have to list all project and give themselves appropriate permissions to view the project.

This widget could not be displayed.

That's strange. You might want to contact support!

This widget could not be displayed.

I failed to mention that we are using Jira 6.0

This widget could not be displayed.

Are your administrators showing loss of any other admin rights?

This widget could not be displayed.

Hey Michael,

The global permission 'JIRA Administrators' might not be granted to that group. See here how to verify that https://confluence.atlassian.com/display/JIRA/Managing+Global+Permissions

Yep, the jira-administrators group has the Global permission JIRA Administrator. I had already checked that but I checked again to be sure since at this point I am open to any and all ideas. I opened a support ticket, we pay for support, may as well use it.

I discovered if I try to create a project with the same name that I get a permission violation for it will actually tell me a project with that name already exists. However, it doesn't appear in the list of projects. Something is certainly amiss.

Michael,

I installed JIRA 6.4 trial server recently and I have discovered that a JIRA system administrator does not get this error. I also discovered in my setup that when I had someone replicate the error, the project was created, but only the System Administrator(s) can see it. Furthermore, the system administrator account is a JIRA Internal Directory account VS an M$ active directory account. I have done all I could with granting global permissions to that group but I still get the error.

This widget could not be displayed.

Hey,
I have the same PRoblem, I create as Administrator a Project, it tells me "

Permission Violation

It seems that you have tried to perform an operation which you are not permitted to perform.

If you think this message is wrong, please contact your JIRA administrators."

In the Logfile I can see "[web.action.browser.BrowseProject] Specified project id to browse, but it is diff to current project. Most prob a permission violation (or it doesn't exist) "

but it creates the project...so what is going on here?

A solution would be very nice!!!

The solution is above in my answer (I answered my own question)

This widget could not be displayed.

ahh damn I totaly overread it, thanks a lot :)

This widget could not be displayed.

Here are my logs (Jira v6.0.8) :

2013-10-21 14:04:40,440 http-bio-8080-exec-751 INFO admin 844x58714x1 1m3xfip 109.135.2.61,0:0:0:0:0:0:0:1 /rest/project-templates/1.0/templates [fields.config.manager.FieldConfigSchemeManagerImpl] ConfigScheme MIP: Simple Issue Tracking Issue Type Scheme (10600). Created with no associated contexts
2013-10-21 14:04:40,694 http-bio-8080-exec-751 INFO admin 844x58714x1 1m3xfip 109.135.2.61,0:0:0:0:0:0:0:1 /rest/project-templates/1.0/templates [atlassian.jira.workflow.OSWorkflowManager] User 'admin(admin)' updated workflow 'MIP: Simple Issue Tracking Workflow' at 'Mon Oct 21 14:04:40 CEST 2013'
2013-10-21 14:04:41,037 http-bio-8080-exec-751 INFO admin 844x58715x1 1m3xfip 109.135.2.61,0:0:0:0:0:0:0:1 /browse/MIP [web.action.browser.BrowseProject] Specified project id to browse, but it is diff to current project. Most prob a permission violation (or it doesn't exist)

This widget could not be displayed.

I have this issue too .. that is because when JIRA Administrator created the project they do not have the rights to browse the project. Go to Setting --> Project --> you should be able to browse your project that and you have to allow JIRA Administrator in the "Browse Project" Permission. Sounds stupid but it works for me. 

 

This widget could not be displayed.

I also encountered this issue, but it was after making a change to the Default Permissions Scheme.  Too many users were using this scheme for multiple projects, and then changing it, which affected other user projects.  If you have this issue, confirm that the Default Permissions Scheme has the Browse permission set for the jira-administrator group.

You have too many people with admin rights - you shouldn't be allowing people the right to change schemes when they don't understand the impacts. The optimal number of Jira admins is 3-5, all with enough knowledge to understand that schemes are shared.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

191 views 18 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you