Jira 5.0 Custom Service

Dear All,

I have a custom service for Jira. This is working on Jira 4.1.2. But this is not working on Jira 5.0.

I am getting following error durin service add.

Error adding service: com.atlassian.jira.service.ServiceException: Unable to get ObjectConfiguration for Service 'null'

following is my sample code:

public ObjectConfiguration getObjectConfiguration() throws ObjectConfigurationException {

return getObjectConfiguration("issuelink", "services/com/atlassian/jira/service/services/MyIssueLinkService/MyIssueLinkService.xml", null);

}

This is an version 2 Plugin.

Please help.

1 answer

1 accepted

Accepted Answer
1 vote

return getObjectConfiguration("issuelink", "services/com/atlassian/jira/service/services/MyIssueLinkService/MyIssueLinkService.xml", null);
Here you need to write only folders under src/main/resurces
For example

public ObjectConfiguration getObjectConfiguration() throws

ObjectConfigurationException {

return getObjectConfiguration("MYNEWSERVICE", "com/jtricks/

services/myjtricksservice.xml", null);

}

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

122 views 6 8
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you