JSON Importer - Why am I getting "Version does not exist for project" messages on the import log?

Importing into existing project. Using - "fixedVersions": ["14.001"], - and 14.001 is a version defined for the project. Full log message states:

Version does not exist for project: 'ExternalProject[jiraId=10044,id=<null>,externalName=<null>,name=MY Project,key=DEV,url=<null>,lead=<null>,description=<null>,projectCategoryName=<null>,avatarUrl=<null>,assigneeType=<null>,versions=<null>,components=<null>,issues=[ExternalIssue{externalId=717311, summary=My Summary, issueType=Enhancement}],workflowSchemeName=<null>]' : and version: '14.001'.
 
I also have the same issue with components. 
 
The issue otherwise imports correctly. 
 
On JIRA 5.2.7, using JIM 5.0.4. 

1 answer

I run to same issue - it's stupid but you need to include all versions and components which you refer from the issues seciton.

Example:

"issues": [

{

"issueType" :"Bug",

"priority" : "4",

"summary" : "habla",

"components" : [ "XY" ],

"affectedVersions" : [ "VersionX" ],

...

then you have include

"components": [ "XY" ],

"version" : [ "VersionX" ],

in project definition part

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published 16 hours ago in Off-topic

Get to know our Atlassian User Group Leaders from Bengaluru, India

Meet @Dinesh Dhinakaran, @Vishnu Vasudeva, @Rajeev Verma, and Jamshid Nalakath: Our extraordinary AUG leaders from Bengaluru, India. These four work together to strengthen the bonds of their local co...

116 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you