JMeter errors while running load testing on JIRA 6.1.1

I am getting below errors while running Performance Load testing using Jmeter on JIRA 6.1.1

Followed : https://confluence.atlassian.com/display/JIRA/Performance+Testing+Scripts

#### sh ./jakarta-jmeter-2.3.4-atlassian-1/bin/jmeter -n -t ./performanceTest/jmeter-test-setup.jmx -Jadmin.user=admin -Jadmin.pass=admin -Jjira.host=jira-fm-dev.devtools.xxxx.com -Jjira.port=8080

Created the tree successfully using ./performanceTest/jmeter-test-setup.jmx

Starting the test @ Wed Nov 13 18:05:20 GMT 2013 (1384365920237)

Waiting for possible shutdown message on port 4445

Generate Summary Results + 277 in 39.5s = 7.0/s Avg: 87 Min: 32 Max: 930 Err: 206 (74.37%)

Generate Summary Results + 6502 in 180.0s = 36.1/s Avg: 53 Min: 20 Max: 402 Err: 5619 (86.42%)

Generate Summary Results = 6779 in 219.6s = 30.9/s Avg: 54 Min: 20 Max: 930 Err: 5825 (85.93%)

Generate Summary Results + 6806 in 180.0s = 37.8/s Avg: 53 Min: 19 Max: 410 Err: 5898 (86.66%)

Generate Summary Results = 13585 in 399.5s = 34.0/s Avg: 54 Min: 19 Max: 930 Err: 11723 (86.29%)

Generate Summary Results + 6836 in 180.1s = 38.0/s Avg: 48 Min: 19 Max: 355 Err: 5923 (86.64%)

JMeter log :

2013/11/13 18:05:50 ERROR - jmeter.protocol.http.sampler.HTTPSampler: Cause: java.io.IOException: Server returned HTTP response code: 500 for URL: http://jira-fm-dev.devtools.xxxx.com:8080/secure/CreateIssueDetails.jspa

2013/11/13 18:05:50 INFO - jmeter.protocol.http.sampler.HTTPSampler: Error Response Code: 500

2013/11/13 18:05:50 ERROR - jmeter.protocol.http.sampler.HTTPSampler: readResponse: java.io.IOException: Server returned HTTP response code: 500 for URL: http://jira-fm-dev.devtools.xxxx.com:8080/secure/CreateIssueDetails.jspa

2013/11/13 18:05:50 ERROR - jmeter.protocol.http.sampler.HTTPSampler: Cause: java.io.IOException: Server returned HTTP response code: 500 for URL: http://jira-fm-dev.devtools.xxxx.com:8080/secure/CreateIssueDetails.jspa

2013/11/13 18:05:50 INFO - jmeter.protocol.http.sampler.HTTPSampler: Error Response Code: 500

2013/11/13 18:05:50 INFO - jmeter.threads.JMeterThread: Thread started: Create Issues 8-14

2013/11/13 18:05:51 ERROR - jmeter.protocol.http.sampler.HTTPSampler: readResponse: java.io.IOException: Server returned HTTP response code: 500 for URL: http://jira-fm-dev.devtools.xxxx.com:8080/secure/CreateIssueDetails.jspa

2013/11/13 18:05:51 ERROR - jmeter.protocol.http.sampler.HTTPSampler: Cause: java.io.IOException: Server returned HTTP response code: 500 for URL: http://jira-fm-dev.devtools.xxxx.com:8080/secure/CreateIssueDetails.jspa

JIRA logs :

2013-11-13 18:06:05,542 http-bio-8080-exec-21 ERROR anonymous 1086x740x1 xtvxtl 10.18.46.169 /secure/CreateIssue.jspa [web.action.issue.CreateIssue] java.lang.NumberFormatException: For input string: "PROJECT_ID_REGEX_FAILED_DDD project"

java.lang.NumberFormatException: For input string: "PROJECT_ID_REGEX_FAILED_DDD project"

at java.lang.NumberFormatException.forInputString(Unknown Source)

at java.lang.Long.parseLong(Unknown Source)

at java.lang.Long.<init>(Unknown Source)

at com.atlassian.jira.issue.fields.ProjectSystemField.getRelevantParams(ProjectSystemField.java:177)

at com.atlassian.jira.issue.fields.AbstractOrderableField.populateFromParams(AbstractOrderableField.java:184)

at com.atlassian.jira.web.action.issue.IssueCreationHelperBeanImpl.validateProject(IssueCreationHelperBeanImpl.java:228)

at com.atlassian.jira.web.action.issue.CreateIssue.doValidation(CreateIssue.java:118)

at webwork.action.ActionSupport.validate(ActionSupport.java:391)

at webwork.action.ActionSupport.execute(ActionSupport.java:162)

Did anyone of you face similar issue, any help you be highly appreciated.

2 answers

Your log log is self-explanatory. It looks like that your logic which extracts Project ID is flaky, JIRA expects Project ID to be a number and your test is trying to feed to JIRA something else. Add Debug Sampler and View Results Tree listener to the end of your Thread Group to see what's being posted, what is Project ID and where is the failure. I guess that it's kind of issue with your Regular Expression Extractor Post Processor. Some http://community.blazemeter.com/knowledgebase/articles/65150-using-regex-regular-expression-extractor-with-jm

Got any sucess on this matter? I have the same issue :(

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

309 views 4 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you