JIRA download not feasible

While trying to download a 5.x.x version of JIRA, I get a 404 warning message. For instance I tried directly downloading version 5.0.7 with the following link without any luck.


same applies for 5.1.8 as well


3 answers

1 accepted

Seems that something was wrong with my browser. Everything solved.

0 vote

Works fine for me when I go via the downloads page.

I suspect it's the host redirecting you to a temporary url for some reason. Try it from the downloads page instead of a direct link.

0 vote
Joe Wai Tye Atlassian Team Nov 07, 2012

Yes, it seems that for some reason you were redirected to another website when you try to download it. Please try using this link : http://www.atlassian.com/software/jira/download

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted yesterday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

168 views 12 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot