Is there an easy way to create a Play SQL Spreadsheet from an existing Excel sheet or CSV?

Copy/Paste would work for me as well, but that does not appear to be possible.

1 answer

1 accepted

Hi Ray,

Copy/Paste is supposed to work. Can you tell exactly how you try? Which browser do you have?

  • Create a spreadsheet,
  • Add a row,
  • The row appears in edit mode (in yellow). Press Enter so it appears in white,
  • Press Ctrl + V. All values should be pasted.

Hi Adrien,

I am using Chrome, but also tried this on Safari to the same effect. When I click into the cell, it simply pastes all values from the copied rows and columns into the one cell. (If I do NOT click into the cell when I attempt to paste, nothing happens.)

See attached video capture (I renamed the extension "jpg" but it is actually an "mp4" file ... not sure if it uploaded).

Screen shot:

Thanks,

Ray

Hi Ray,

Thanks for the video! It seems you're in Edit mode when you're attempting to paste the data. I see that because I see the keyboard cursor blinking. You shouldn't be in edit mode.

You should just select the first cell (or press Esc if you're already editing the cell) before pasting, then press Ctrl+V.

Cheers,

Adrien

It makes no difference whether I'm in Edit Mode, or just on a page with a Play SQL Spreadsheet (with Admin privilege level) in View mode: the effect is the same. All data gets jumbled into the same cell. I tried the following:

  1. Copying a number of cells from Excel, and pasting into one cell of the Play SQL Spreadsheet (after pressing Esc, as you suggest above) ... nothing at all happens.
  2. Copying a number of cells from Excel, and pasting into one cell of the Play SQL Spreadsheet (while the cursor is blinking in the field) ... all data gets pasted into one cell, instead of many.
  3. First creating the same number of blank rows and columns in the Play SQL Spreadsheet as the number of rows and columns I am copying from Excel, just to see if it is looking to match up the row/column area ... this did not work either.

I am on a Mac 10.7.5, using a trial version of the latest version of your plugin (2.6.3-SNAPSHOT), and copying from Excel:mac 2011 (v 14.1.4). More context: our Atlassian consultant, Michael March of ISOS Technology, worked through a bug with you last week, where there was some issue with the Tomcat proxy (as I understand it), which you fixed (thanks!). Don't know if that sheds any light.

We are looking to purchase the plugin this week, so hopefully we can resolve this. Let me know if you would like to do a screen sharing, I can send you an email with my info.

Regards,
Ray

Hi Ray, Another customer confirms it doesn't work in 2.6.3 and it worked in 2.5, so you're right in your observations. This must have been introduced recently. I'll investigate in the next 5hrs and if everything goes well, I should deliver a fix in 12hrs. Thank you very much for providing the details you described, they will be helpful in reproducing. Best regards, Adrien

Hi Ray,

I've just fixed it (PLAYSQL-62) an published a new Play SQL version (2.6.4). I'm sorry that I introduced this bug in Play SQL 2.6.2 and didn't catch it before.

Hope it will be satisfying for you,

Adrien

Thanks Adrien! I will check it out once the "Update" button shows up in my Add-Ons management page (just so I can get the official release).

Hi Adrien,

It is working now, but just a couple of issues... when you paste multiple values that end in the same integer, it automatically attempts to advance the number for each row (see screen shot ... in this case, all rows were copied as "FileMaker Pro 12").

Regards,

Ray

Great, happy it works now, thanks for confirming.

This does indeed work now, thanks Adrien!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

124 views 6 8
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you