Index not getting processed automatically in Confluence 4.0

Hello everyone,
We use Confluence 4.0 and had the issue with the large queue content (Number of items in queue: 4961) in the content indexing. Actually, we are trying to test Community Bubbles's forum features and I added a test forum page. When I tried finding this page, it doesn't show-up in the search results, although I can navigate to this page using Advanced->Orphaned Pages. So, I wanted to know how often the indexing is done in Confluence and searched for the log files for index. But I could not find a separate log file for indexing. Can anyone help me locate that file? Also, I do not think that automatic indexing is processed for our confluence which might be the root cause of the issue.
I researched online for this issue and found this resolution: https://confluence.atlassian.com/display/CONFKB/Confluence+Fails+to+Process+Index+Queue+Automatically
Referring this, I first restarted Confluence service on the server 2-3 times. The queue content gradually reduced in each restart; finally it is empty now. After this step, I tried searching a page called Test_page which I created in Knowledge Base sometime ago (which I can still navigate to in Orphaned pages) but still the same issue. So, the next step I took was to build the index again. But this also didn't help as I tried searching the page again and I was getting the same error: "No results found for ancestorIds:12980452 AND Test_page. Please try one of the following suggestions: Use more general search terms. If you are filtering by space, content, last modification date or contributor, try removing or adjusting the filter"

Also, I have checked the logs of Confluence and I don't see any Out-of-Memory error in the error log. I have attached the support log for your reference.Finally, I have also checked the scheduled jobs in Confluence where it says the last "clean index job" was done on Sep 5, 2012 and the next one will be done tomorrow i.e. on Sept 20th. All of the future "clean index queue" job will happen everyday. I have attached a snapshot of Scheduled jobs for reference. So, this is also confusing...why was there a gap of 15 days for this job? ()

1 answer

1 accepted

This widget could not be displayed.

Hello Neeraj,

A quick thought. If your Databse server and your application server are two seperate machines we want to make sure that both machines are set to the same system time.

Did the problem start happening after you installed the Community bubbles plugin? If so you may wish to remove it..

My other thought is that you may benefit from an index from scratch operation. Your index may have been corrupted in some way that is not allowing further changes to be made. The steps in the following document will walk you though this process.

https://confluence.atlassian.com/display/CONFKB/Rebuild+the+Content+Indices+from+Scratch

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 59m ago in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

8 views 0 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you