It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Inconsistent REST behaviour.

DaveF Jul 06, 2017

Trying to get familiar with REST calls and require some assistance. The problem that I am facing is different behavour in two different projects on the same instance when called from two different environments on my local machine.

Looking at the following calls:

http://jira.hk.xxx/rest/api/2/project/PLR/versions
http://jira.hk.xxx/rest/api/2/project/FIT/versions
https://jira.hk.xxx/rest/api/latest/issue/PLR-3933
https://jira.hk.xxx/rest/api/latest/issue/FIB-14736

When I make the calls in Chrome data is returned, however when I run via VBA in Excel (2010) using the WinHTTP library The calls to FIT succeed while the calls to PLR fail.

I get different errors for the calls in Excel:

When I call for projects the error is "No project could be found with key 'PLR'."
When I call for a single PLR issue the error is "You do not have the permission to see the specified issue.
Login Required"


It feels like the difference is at the project level but I'm at a loss as to where to check.

1 answer

1 accepted

0 votes
Answer accepted
Dario Bonotto Atlassian Team Jul 06, 2017

Hi Dave,

 

How are you authenticating the REST calls you run via VBA? Are you using the same credentials you use to log-into the UI? 

I am asking this because from the error message this seems to be a permission issue and the account used in VBA has no rights to see project PLR.

Also, can you reproduce the issue by using Curl?

curl -D- -u USERNAME:PASSWORD  -H "Accept: application/json" -H "Content-Type: application/json" -X GET http://jira.hk.xxx/rest/api/2/project/PLR/versions


curl -D- -u USERNAME:PASSWORD  -H "Accept: application/json" -H "Content-Type: application/json" -X GET https://jira.hk.xxx/rest/api/latest/issue/PLR-3933


Best Regards,
Dario
Atlassian Cloud Support

 

DaveF Jul 06, 2017

Hi Dario,

Thank you for your reply, in my test case I'm not authenticatiing in either case.  If I do authenticate it makes no difference to the outcome.

If I make the call to the "FIT" project everything is fine no matter how many times I make the call. Even if I call "PLR" directly after the "FIT" calls they fail. I can immediately go back to "FIT" and the call works.

The calls also both work in in Chrome but not from VBA.

Kind regards

Dave

 

Dario Bonotto Atlassian Team Jul 06, 2017

Hi Dave,

This sounds definitely like a permission problem. 

Please open a support request in support.atlassian.com to have this issue further investigated.


Best Regards,
Dario
Atlassian Cloud Support

DaveF Jul 17, 2017 • edited

Dario you were absolutely correct. In hindsight it is obvious that my cedentials were being held in in the browser. 

I finally found out how to authenticate in VBA in this youtube viedo:  https://www.youtube.com/watch?v=jGvmmjVUKuM

Kind regards


Dave

Dario Bonotto Atlassian Team Jul 18, 2017 • edited

Nice to hear so @DaveF :) 

 

Please mark this question as resolved and, if you like to, vote for my answer.

 

Have a nice day!

Dario

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted in United States

Topic Tuesday: Agile

Another week, another Topic Tuesday!  Agile has been on my mind a lot lately because I've seen good implementations and bad implementations, but now as a Jira admin it matters more to me whether...

7 views 0 0
View post

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you