Images not appearing in Word imports

I've got some word documents coming from a weird source. They originate in Framemaker. Framemaker does a much better job exporting to html than rtf, so I pickup the html and doctor it a bit to remove junk that Framemaker produces. Then I open the html in Word, save it as Word files and then do the confluence import. Problem is, the images get lost. They're there in word, from the html, but confluence doesn't pick them up.

Does anybody know what might be happening here? It's really a bummer to have to figure out which images from the original framemaker belong where in confluence.

3 answers

1 accepted

This widget could not be displayed.

I love a good mystery, but there have been a couple too many lately. I'll let this one go as such. I'm importing into a single page without splitting and the bug is about document splitting. I suspect there's something in the way that Word transforms html that confuses the importer. Of course, Microsoft developers wouldn't know this was happening if images were perfectly visible in Word. I have tried importing from a slightly different direction, and I don't lose the images but, worse, I lose all structure.

This widget could not be displayed.

Hello Tim, turns out we have a reported bug for images not getting to the application when using the Word Import, it is documented in CONF-21852. You may like to add yourself as a watcher and describe your usage scenario as well.

Hope this helps.

Thanks, Guilherme, for bringing pointing this out. It turns out that this bug is about problems with word documents that are being split and (I didn't mention this but) I'm importing as a single document.

This widget could not be displayed.

I love a good mystery, but there have been a couple too many lately. I'll let this one go as such. I suspect there's something in the way that Word transforms html that confuses the importer. Of course, Microsoft developers wouldn't know this was happening if images were perfectly visible in Word. I have tried importing from a slightly different direction, but, worse than losing images, I lose all structure.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in United States

Local Atlassian Research Workshop opportunity on Sep. 28th

We're looking for participants for another workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sh...

37 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you