I can't upload edited Office documents back to Confluence

We're evaluating Confluence on-demand as a document repository. We mostly use Win7 and Office 2010, the browser is typically IE.

I've uploaded original documents (docx and xlsx) for testing. I can open them to edit from within Confluence, but when I try to save-and-upload from the editing application (excel or word) the application responds with

"upload failed. your changes were saved (locally) but could not be uploaded because of an error"

What could be causing this? where do I start? Thanks.

5 answers

This widget could not be displayed.

This is a current known issue with Confluence: https://jira.atlassian.com/browse/CONF-26911

We are currently working on a fix, but it probably won't be ready for a couple of weeks yet.

This widget could not be displayed.

Despite the error message, can you check if it has uploaded successfully?

Do you have office in protected mode?

Thanks for the replies. When the document opens, it is "edit disabled" until I click the "enable editing" button that MSO provides (this is office 2010, BTW).

The document is not uploaded due to the failure. If I re-open the doc from Confluence, none of my edits are present. So the online and offline versions of the doc are now out of sync. The MSO upload manager continues to show me the failed uploads, but offers no assistance to overcoming the issue.

This widget could not be displayed.

We have this issue too. After extensive back and forth communications with support, the conclusion is the same as Michael Knight's answer above.

This widget could not be displayed.
This seems to still be an issue with Confluence 5.1.3 standalone with java 1.7.0_21. When attempting to "edit in office" and save docx or xlsx error message "Upload failed Your changes were saved but could not be uploaded because of an error. You may be able to upload this file using the server web page." is displayed. Using Office Connector Plugin 3.0.3.

Based on a comment by sap in https://jira.atlassian.com/i#browse/CONF-26911 I have verified that in voth confluence standalone 4.1.10 & 5.1.3 if I have jave 1.7.x in use I get the error. If I switch to java 1.6.x "edit in office" works fine and I can save without problem or error. Of course staying with 1.6.x is not really an option.

This widget could not be displayed.

I'm having the same problem described in the original October 2012 post.

Has this issue been solved in the 5 1/2 years since it was posted?

Thanks.

I am on Atlassian 5.10.07 and experiened the problem myself. This is with Office 2013 and Edge. I tried IE but I get an ActiveX error which seems to be security related

Facing the same issue on Confluence 6.0.3, using MSO 2016. I used to be able to do this and my colleagues are still able to, but it is not possible from my PC

Gonchik Tsymzhitov Community Champion Jan 10, 2018

Hello Paulius,

Could you provide error logs from catalina.out?

In fact, on Confluence 6.6.0 with MSO 2016 it works.

 

Cheers,

Gonchik Tsymzhitov

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 5 hours ago in Europe

Topic Tuesday: How did you learn about the AUG programme?

Back in 2010 I hadn't been using the Atlassian tools (JIRA, Confluence, Bamboo) that long and I started searching online to see if I could chat to other users primarily about how they used the produc...

13 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you