How do I set up rsyslog.d rsyslog.conf properly in hipchat when using mycompany.conf file? Edited

Our rsyslog.d conf file works fine for all our other Atlassian servers.  I have edited the "in the box" /rsyslog.d/server.conf file replacing the ~ with 'stop' and commenting out the facility 'web' section all shown from rsyslog.com as outdated or invalid.  Afterwhich "rsyslogd -N1" runs clean.  So again, the only errors I see were with what comes with a clean hipchat install.  With those cleaned up, I still cannot make rsyslog work at all.  I have confirmed no firewall issues.  

Lastly, if there is not a solution to this, is there a posting/article anywhere from hipchat support advising not to alter rsyslog.d?

Any help would be greatly appreciated.

1 answer

It ended up being a firewall issue.  The built in iptables was blocking our syslogging.  We disabled iptables on the hipchat server, and our syslog server started receiving as expected.  We have our own firewalls and wont need the builtin iptables.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Uncategorized

Friday fun: how many celebrates Midsummer holiday or is this a Swedish tradition only?

Any other country that celebrates Midsummer holiday (this friday 22 June)?  

44 views 3 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you